summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-06-26 01:47:25 +0000
committerSteve Dibb <beandog@gentoo.org>2008-06-26 01:47:25 +0000
commit41ffbe36a81ec7cac062076459a58f15e7806452 (patch)
tree3f652ef46495adc4d2a4fee4383740ad719e15db /app-text/gnomesword
parentFix bugs #212970, #192296, #217507. Text dbmode is the only one left supporte... (diff)
downloadgentoo-2-41ffbe36a81ec7cac062076459a58f15e7806452.tar.gz
gentoo-2-41ffbe36a81ec7cac062076459a58f15e7806452.tar.bz2
gentoo-2-41ffbe36a81ec7cac062076459a58f15e7806452.zip
Fix gcc 4.3 compilation, bug 226659, thanks to Marek Miller for patch; Add missing dep, bug 227145
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-tuxonice-r3 x86_64)
Diffstat (limited to 'app-text/gnomesword')
-rw-r--r--app-text/gnomesword/ChangeLog9
-rw-r--r--app-text/gnomesword/files/gnomesword-gcc43.patch30
-rw-r--r--app-text/gnomesword/gnomesword-2.3.1-r2.ebuild51
3 files changed, 89 insertions, 1 deletions
diff --git a/app-text/gnomesword/ChangeLog b/app-text/gnomesword/ChangeLog
index bdaf6bc712c1..3409d9a05ddd 100644
--- a/app-text/gnomesword/ChangeLog
+++ b/app-text/gnomesword/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gnomesword
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.28 2008/05/02 15:02:37 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/ChangeLog,v 1.29 2008/06/26 01:47:25 beandog Exp $
+
+*gnomesword-2.3.1-r2 (26 Jun 2008)
+
+ 26 Jun 2008; Steve Dibb <beandog@gentoo.org>
+ +files/gnomesword-gcc43.patch, +gnomesword-2.3.1-r2.ebuild:
+ Fix gcc 4.3 compilation, bug 226659, thanks to Marek Miller for patch; Add
+ missing dep, bug 227145
02 May 2008; Doug Goldstein <cardoe@gentoo.org> gnomesword-2.1.7.ebuild,
gnomesword-2.3.1-r1.ebuild:
diff --git a/app-text/gnomesword/files/gnomesword-gcc43.patch b/app-text/gnomesword/files/gnomesword-gcc43.patch
new file mode 100644
index 000000000000..31fb4edf14e1
--- /dev/null
+++ b/app-text/gnomesword/files/gnomesword-gcc43.patch
@@ -0,0 +1,30 @@
+--- src/backend/sword_main.hh.orig 2008-06-15 12:43:54.000000000 +0000
++++ src/backend/sword_main.hh 2008-06-15 12:44:24.000000000 +0000
+@@ -22,7 +22,7 @@
+ #ifndef _SWORD_MAIN_HH_
+ #define _SWORD_MAIN_HH_
+
+-
++#include <string>
+ #include <swmgr.h>
+ #include <swbuf.h>
+ #include <versekey.h>
+
+--- src/main/display.hh.orig 2008-06-15 12:45:19.000000000 +0000
++++ src/main/display.hh 2008-06-15 12:45:59.000000000 +0000
+@@ -25,13 +25,13 @@
+ #endif
+
+ #ifdef __cplusplus
++#include "backend/sword_main.hh"
+ extern "C" {
+
+ #include <gtk/gtk.h>
+ #include <swmgr.h>
+ #include <swdisp.h>
+ #include "main/global_ops.hh"
+-#include "backend/sword_main.hh"
+ #include "gui/utilities.h"
+
+ using namespace sword;
+
diff --git a/app-text/gnomesword/gnomesword-2.3.1-r2.ebuild b/app-text/gnomesword/gnomesword-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..f5e17ab5ffcd
--- /dev/null
+++ b/app-text/gnomesword/gnomesword-2.3.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnomesword/gnomesword-2.3.1-r2.ebuild,v 1.1 2008/06/26 01:47:25 beandog Exp $
+
+inherit libtool gnome2 eutils
+
+DESCRIPTION="Gnome Bible study software"
+HOMEPAGE="http://gnomesword.sf.net/"
+SRC_URI="mirror://sourceforge/gnomesword/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="firefox seamonkey spell xulrunner"
+RDEPEND=">=gnome-extra/gtkhtml-3.14
+ =app-text/sword-1.5.10*
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2
+ app-text/gnome-doc-utils
+ dev-libs/libxml2
+ xulrunner? ( =net-libs/xulrunner-1.8* )
+ !xulrunner? ( firefox? ( =www-client/mozilla-firefox-2* ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( =www-client/seamonkey-1* ) ) )
+ spell? (
+ app-text/gnome-spell
+ >=gnome-base/libbonoboui-2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.14"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable spell pspell)"
+ DOCS="NEWS ChangeLog README TODO"
+}
+
+src_unpack() {
+ unpack $A
+ cd "${S}"
+ # bug 226659
+ epatch "${FILESDIR}/${PN}-gcc43.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Gnomesword requires modules to be of any use. You may install the"
+ einfo "sword-modules package, or download modules individually from the"
+ einfo "sword website: http://crosswire.org/sword/"
+}