summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-04-12 16:07:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-04-12 16:07:17 +0000
commitf23687f440f33dec387bd03671b25b69189672d5 (patch)
tree5628a4edbf196c7cbbd2d55baffcaa2fa4566d5b /app-text/gonzui
parentstable amd64, 86478 (diff)
downloadgentoo-2-f23687f440f33dec387bd03671b25b69189672d5.tar.gz
gentoo-2-f23687f440f33dec387bd03671b25b69189672d5.tar.bz2
gentoo-2-f23687f440f33dec387bd03671b25b69189672d5.zip
Initial import. Ebuild provided by bashi.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text/gonzui')
-rw-r--r--app-text/gonzui/ChangeLog10
-rw-r--r--app-text/gonzui/Manifest2
-rw-r--r--app-text/gonzui/files/digest-gonzui-1.11
-rw-r--r--app-text/gonzui/files/ebuild.rb39
-rw-r--r--app-text/gonzui/files/gonzui33
-rw-r--r--app-text/gonzui/gonzui-1.1.ebuild42
-rw-r--r--app-text/gonzui/metadata.xml10
7 files changed, 137 insertions, 0 deletions
diff --git a/app-text/gonzui/ChangeLog b/app-text/gonzui/ChangeLog
new file mode 100644
index 000000000000..c100f1c3144e
--- /dev/null
+++ b/app-text/gonzui/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/gonzui
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/ChangeLog,v 1.1 2005/04/12 16:07:17 matsuu Exp $
+
+*gonzui-1.1 (12 Apr 2005)
+
+ 12 Apr 2005; MATSUU Takuto <matsuu@gentoo.org> +files/ebuild.rb,
+ +files/gonzui, +gonzui-1.1.ebuild:
+ Initial import. Thanks to bashi at GentooJP EbuildJP,
+ http://ebuild.gentoo.gr.jp/.
diff --git a/app-text/gonzui/Manifest b/app-text/gonzui/Manifest
new file mode 100644
index 000000000000..b1e66cbab2ae
--- /dev/null
+++ b/app-text/gonzui/Manifest
@@ -0,0 +1,2 @@
+MD5 c7946c9e26b9e41ef80fc29d2e97d123 gonzui-1.1.ebuild 982
+MD5 0dd0e97ce440d47373a5b47a202b7937 files/digest-gonzui-1.1 62
diff --git a/app-text/gonzui/files/digest-gonzui-1.1 b/app-text/gonzui/files/digest-gonzui-1.1
new file mode 100644
index 000000000000..c7abd50a8893
--- /dev/null
+++ b/app-text/gonzui/files/digest-gonzui-1.1
@@ -0,0 +1 @@
+MD5 5390d7d55362610a5c36ef688e1dd428 gonzui-1.1.tar.gz 436556
diff --git a/app-text/gonzui/files/ebuild.rb b/app-text/gonzui/files/ebuild.rb
new file mode 100644
index 000000000000..31676e4e64ec
--- /dev/null
+++ b/app-text/gonzui/files/ebuild.rb
@@ -0,0 +1,39 @@
+#
+# ebuild.rb - a ebuild module of LangScan
+#
+# Copyright (C) 2005 Kenichi Ishibashi <bashi at dream.ie.ariake-nct.ac.jp>
+# All rights reserved.
+# This is free software with ABSOLUTELY NO WARRANTY.
+#
+# You can redistribute it and/or modify it under the terms of
+# the GNU General Public License version 2.
+#
+
+require 'langscan/sh'
+require 'langscan/_common'
+
+module LangScan
+ module Ebuild
+ module_function
+ def name
+ "ebuild"
+ end
+
+ def abbrev
+ "ebuild"
+ end
+
+ def extnames
+ [".ebuild", ".eclass"]
+ end
+
+ # LangScan::Ebuild.scan iterates over shell scripts.
+ # It yields for each element which is interested by gonzui.
+ def scan(input, &block)
+ # delegate to LangScan::Shell.scan
+ LangScan::Shell.scan(input, &block)
+ end
+
+ LangScan.register(self)
+ end
+end
diff --git a/app-text/gonzui/files/gonzui b/app-text/gonzui/files/gonzui
new file mode 100644
index 000000000000..de1e9c493528
--- /dev/null
+++ b/app-text/gonzui/files/gonzui
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/files/gonzui,v 1.1 2005/04/12 16:07:17 matsuu Exp $
+
+GONZUI_SERVER=/usr/bin/gonzui-server
+GONZUIRC=/etc/gonzuirc
+GONZUI_PIDFILE=/var/run/gonzui.pid
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -f "$GONZUIRC" ] ; then
+ eerror "Please create $GONZUIRC"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+ ebegin "Starting gonzui"
+ start-stop-daemon --start --quiet --exec $GONZUI_SERVER -- --daemon --gonzuirc=$GONZUIRC --quiet
+ eend $? "Failed to start gonzui"
+}
+
+stop() {
+ ebegin "Stopping gonzui"
+ start-stop-daemon --stop --quiet --pidfile $GONZUI_PIDFILE
+ eend $? "Failed to stop gonzui"
+}
diff --git a/app-text/gonzui/gonzui-1.1.ebuild b/app-text/gonzui/gonzui-1.1.ebuild
new file mode 100644
index 000000000000..66f25aea5e29
--- /dev/null
+++ b/app-text/gonzui/gonzui-1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/gonzui-1.1.ebuild,v 1.1 2005/04/12 16:07:17 matsuu Exp $
+
+inherit eutils ruby
+
+IUSE=""
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="gonzui is a source code search engine."
+HOMEPAGE="http://gonzui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gonzui/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=virtual/ruby-1.8.2
+ >=sys-libs/db-4.2
+ >=dev-ruby/ruby-bdb-0.5.2
+ dev-ruby/ruby-progressbar"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/ebuild.rb ${S}/langscan
+ sed -i -e "s/rubylib_DATA = /rubylib_DATA = ebuild.rb /" \
+ ${S}/langscan/Makefile.in || die
+}
+
+src_install() {
+ ruby_src_install
+ mv ${D}/etc/gonzuirc.sample ${D}/etc/gonzuirc
+ doinitd ${FILESDIR}/gonzui
+ keepdir /var/lib/gonzui
+ keepdir /var/log/gonzui
+}
+
+pkg_postinst() {
+ einfo "The database (gonzui.db) format has become incompatible with"
+ einfo "older versions."
+ einfo "Please restructure the database if you already have it."
+}
diff --git a/app-text/gonzui/metadata.xml b/app-text/gonzui/metadata.xml
new file mode 100644
index 000000000000..6b38257098f4
--- /dev/null
+++ b/app-text/gonzui/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+<name>MATSUU Takuto</name>
+</maintainer>
+</pkgmetadata>
+