summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-03-08 22:05:57 +0000
committerMarinus Schraal <foser@gentoo.org>2003-03-08 22:05:57 +0000
commitf8c7cad78c1bbed8fda1584eba86ba13836ef807 (patch)
treece8c4753664f688a1510c18198f19ab1ccbdfd33 /app-text/gtkspell
parentinheriting eutils (diff)
downloadgentoo-2-f8c7cad78c1bbed8fda1584eba86ba13836ef807.tar.gz
gentoo-2-f8c7cad78c1bbed8fda1584eba86ba13836ef807.tar.bz2
gentoo-2-f8c7cad78c1bbed8fda1584eba86ba13836ef807.zip
bugfix
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog6
-rw-r--r--app-text/gtkspell/gtkspell-2.0.4.ebuild20
2 files changed, 21 insertions, 5 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index dbbec76b49ff..5a1d1e221053 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-text/gtkspell
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.10 2003/03/08 04:13:26 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.11 2003/03/08 22:05:57 foser Exp $
*gtkspell-2.0.4 (07 Mar 2003)
+ 08 Mar 2003; foser <foser@gentoo.org> gtkspell-2.0.4.ebuild :
+ real gtkdoc fix, removed line from configure to make the switch actually work
+ see bug #16997
+
08 Mar 2003; Martin Schlemmer <azarah@gentoo.org> gtkspell-2.0.4.ebuild :
Add 'doc' support with DEPEND on gtk-doc, as it fails over here without
gtk-doc installed ...
diff --git a/app-text/gtkspell/gtkspell-2.0.4.ebuild b/app-text/gtkspell/gtkspell-2.0.4.ebuild
index 55eb35959cb4..ff76fa7a7834 100644
--- a/app-text/gtkspell/gtkspell-2.0.4.ebuild
+++ b/app-text/gtkspell/gtkspell-2.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.4.ebuild,v 1.2 2003/03/08 04:13:26 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.4.ebuild,v 1.3 2003/03/08 22:05:57 foser Exp $
DESCRIPTION="spell library for GTK2"
SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
@@ -13,12 +13,24 @@ IUSE="doc"
DEPEND=">=x11-libs/gtk+-2
>=app-text/aspell-0.50
- doc? ( dev-util/gtk-doc )"
+ doc? ( >=dev-util/gtk-doc-0.6 )"
+
+src_unpack() {
+ unpack ${A}
+
+ # fix the config script's gtkdoc check (bug #16997)
+ cd ${S}
+ mv configure configure.old
+ sed -e "s:GTKDOC=true::" configure.old > configure
+ chmod +x configure
+}
src_compile() {
- myconf=
+ local myconf
- use doc || myconf="--disable-gtk-doc"
+ use doc \
+ && myconf="--enable-gtk-doc" \
+ || myconf="--disable-gtk-doc"
econf ${myconf} || die
emake || die "compile failure"