summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-04-03 05:54:30 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-04-03 05:54:30 +0000
commit9f05c79a734ef734680a432972ad6fe5f0ff903b (patch)
tree96ddf9a887f2ae6e5528459ab9517cb4948e9bff /app-text/gv
parentTesting ppc-macos. Makefile and source patches added for Darwin compatibility. (diff)
downloadgentoo-2-9f05c79a734ef734680a432972ad6fe5f0ff903b.tar.gz
gentoo-2-9f05c79a734ef734680a432972ad6fe5f0ff903b.tar.bz2
gentoo-2-9f05c79a734ef734680a432972ad6fe5f0ff903b.zip
Testing ppc-macos. Bug #86072
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/ChangeLog6
-rw-r--r--app-text/gv/files/gv-3.5.8-setenv.diff21
-rw-r--r--app-text/gv/gv-3.5.8-r4.ebuild7
3 files changed, 31 insertions, 3 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index c2679d188198..9a15a1052240 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gv
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.31 2005/01/02 22:19:01 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.32 2005/04/03 05:54:30 j4rg0n Exp $
+
+ 03 Apr 2005; Lina Pezzella <j4rg0n@gentoo.org>
+ +files/gv-3.5.8-setenv.diff, gv-3.5.8-r4.ebuild:
+ Testing ppc-macos. Bug #86072. Thanks to Benjamin Braatz for reporting
02 Jan 2005; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-text/gv/files/gv-3.5.8-setenv.diff b/app-text/gv/files/gv-3.5.8-setenv.diff
new file mode 100644
index 000000000000..6c4ef2c26b26
--- /dev/null
+++ b/app-text/gv/files/gv-3.5.8-setenv.diff
@@ -0,0 +1,21 @@
+--- source/setenv.c.orig Mon Mar 21 00:17:45 2005
++++ source/setenv.c Mon Mar 21 00:27:46 2005
+@@ -39,7 +39,7 @@
+ */
+ int
+ setenv(name, value, rewrite)
+- register char *name, *value;
++ const char *name, *value;
+ int rewrite;
+ {
+ extern char **environ;
+@@ -97,7 +97,7 @@
+ */
+ void
+ unsetenv(name)
+- char *name;
++ const char *name;
+ {
+ extern char **environ;
+ register char **P;
+
diff --git a/app-text/gv/gv-3.5.8-r4.ebuild b/app-text/gv/gv-3.5.8-r4.ebuild
index 031b5f184a25..8e0311e74317 100644
--- a/app-text/gv/gv-3.5.8-r4.ebuild
+++ b/app-text/gv/gv-3.5.8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r4.ebuild,v 1.10 2005/01/01 16:18:29 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.5.8-r4.ebuild,v 1.11 2005/04/03 05:54:30 j4rg0n Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc alpha sparc amd64 ~mips"
+KEYWORDS="x86 ppc alpha sparc amd64 ~mips ~ppc-macos"
IUSE=""
# There's probably more, but ghostscript also depends on it,
@@ -28,6 +28,9 @@ src_unpack() {
}
src_compile() {
+
+ use ppc-macos && epatch ${FILESDIR}/${P}-setenv.diff
+
cp config.Unix 1
sed -e 's:usr/local:usr:' 1 > config.Unix
sed -i -e "s:SCRATCH_DIR = ~/:SCRATCH_DIR = /tmp/:g" config.Unix