summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-12-03 08:15:09 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2005-12-03 08:15:09 +0000
commit836a3045152b098ef3f837439fd010c0f43104c8 (patch)
tree2e159127d0db898a7d4bb7ac872b5b841ed3410a /app-text/html-xml-utils/html-xml-utils-3.7.ebuild
parentVersion bump (diff)
downloadgentoo-2-836a3045152b098ef3f837439fd010c0f43104c8.tar.gz
gentoo-2-836a3045152b098ef3f837439fd010c0f43104c8.tar.bz2
gentoo-2-836a3045152b098ef3f837439fd010c0f43104c8.zip
Version bump
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-text/html-xml-utils/html-xml-utils-3.7.ebuild')
-rw-r--r--app-text/html-xml-utils/html-xml-utils-3.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/html-xml-utils-3.7.ebuild b/app-text/html-xml-utils/html-xml-utils-3.7.ebuild
new file mode 100644
index 000000000000..d6474a0c162a
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-3.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/html-xml-utils-3.7.ebuild,v 1.1 2005/12/03 08:15:09 pclouds Exp $
+
+inherit eutils
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files."
+SRC_URI="http://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+HOMEPAGE="http://www.w3.org/Tools/HTML-XML-utils/"
+LICENSE="W3C"
+
+IUSE=""
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Replace references to normalize with normalize-html, which
+ # has been renamed due to clash described in #27399
+ sed -i "s:normalize:&-html:g" *.1 || die "sed failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING INSTALL README TODO
+
+ # Check bug #27399, the following binary conflicts with
+ # one provided by the 'normalize' package, so we're
+ # renaming this one <obz@gentoo.org>
+ mv ${D}/usr/bin/normalize ${D}/usr/bin/normalize-html
+ mv ${D}/usr/share/man/man1/normalize.1 \
+ ${D}/usr/share/man/man1/normalize-html.1
+
+}