summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-23 19:14:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-23 19:14:32 +0000
commitd3b9581a32aac53ec50c6310360e4d36ab29b089 (patch)
treed32f55d7609842cd23d33788bc5fba73989e570e /app-text/htmlc/htmlc-2.40.0.ebuild
parentdisable parallel build, bug #453434 (diff)
downloadgentoo-2-d3b9581a32aac53ec50c6310360e4d36ab29b089.tar.gz
gentoo-2-d3b9581a32aac53ec50c6310360e4d36ab29b089.tar.bz2
gentoo-2-d3b9581a32aac53ec50c6310360e4d36ab29b089.zip
version bump: eapi5 and add slot deps, remove useless || die.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text/htmlc/htmlc-2.40.0.ebuild')
-rw-r--r--app-text/htmlc/htmlc-2.40.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/htmlc/htmlc-2.40.0.ebuild b/app-text/htmlc/htmlc-2.40.0.ebuild
new file mode 100644
index 000000000000..7de0974ebd63
--- /dev/null
+++ b/app-text/htmlc/htmlc-2.40.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlc/htmlc-2.40.0.ebuild,v 1.1 2013/07/23 19:14:32 aballier Exp $
+
+EAPI=5
+
+# Override version: 2.4.0 > 2.21.0 so we name it 2.40.0
+MY_P="${P/0[.]/.}"
+
+DESCRIPTION="HTML template files expander"
+HOMEPAGE="http://htmlc.inria.fr/"
+SRC_URI="http://htmlc.inria.fr/${MY_P}.tgz"
+
+LICENSE="htmlc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt"
+# Files for the tests are missing...
+#RESTRICT="test"
+
+DEPEND=">=dev-lang/ocaml-3.11.2:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ ./configure \
+ --install-root-dir "${ED}usr" \
+ || die
+}
+
+src_compile() {
+ if use ocamlopt ; then
+ emake bin
+ else
+ emake byt
+ fi
+}
+
+src_install() {
+ if use ocamlopt ; then
+ emake installbin
+ else
+ emake installbyt
+ fi
+ emake MANDIR='$(PREFIXINSTALLDIR)/share/man/man$(MANEXT)' installman
+ dodoc README Announce* CHANGES
+}