summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-25 17:55:44 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-25 17:55:44 +0000
commit032de2bd2436f6401e1fd93cf6ddadaf37dbb088 (patch)
treedef091d5307b7a93e7f39d73b0fb5705bd50cc5b /app-text/htmldoc
parenttail space removed (diff)
downloadgentoo-2-032de2bd2436f6401e1fd93cf6ddadaf37dbb088.tar.gz
gentoo-2-032de2bd2436f6401e1fd93cf6ddadaf37dbb088.tar.bz2
gentoo-2-032de2bd2436f6401e1fd93cf6ddadaf37dbb088.zip
Now used useflags for config. Closes #29576.
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/ChangeLog5
-rw-r--r--app-text/htmldoc/Manifest4
-rw-r--r--app-text/htmldoc/htmldoc-1.8.23.ebuild26
3 files changed, 20 insertions, 15 deletions
diff --git a/app-text/htmldoc/ChangeLog b/app-text/htmldoc/ChangeLog
index aaa93cb095e1..7a8071b95ad2 100644
--- a/app-text/htmldoc/ChangeLog
+++ b/app-text/htmldoc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/htmldoc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/ChangeLog,v 1.12 2003/09/15 21:15:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/ChangeLog,v 1.13 2003/09/25 17:55:40 mholzer Exp $
+
+ 26 Sep 2003; Martin Holzer <mholzer@gentoo.org> htmldoc-1.8.23.ebuild:
+ Now used useflags for config. Closes #29576.
15 Sep 2003; Aron Griffis <agriffis@gentoo.org> htmldoc-1.8.23.ebuild:
Add ~alpha
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
index d7cc17937b4c..1804584d244b 100644
--- a/app-text/htmldoc/Manifest
+++ b/app-text/htmldoc/Manifest
@@ -1,8 +1,8 @@
-MD5 7b147342720f00b41a752af3bc72053a ChangeLog 1761
+MD5 919e00218a4fa23cd03c955067416b43 ChangeLog 1881
MD5 16aab86277d53e0666468bcb6dd6ec43 htmldoc-1.8.19.ebuild 827
MD5 5d79b92653e823a0cd10f1f354f26c6e htmldoc-1.8.20.ebuild 1155
MD5 12e6e19cf2f6994595fcb994ba56919e htmldoc-1.8.20-r1.ebuild 1380
-MD5 28ad960b285ad05d28867131e836a339 htmldoc-1.8.23.ebuild 1194
+MD5 763efc8b0a3dcc9f5670765c2c7ce1fb htmldoc-1.8.23.ebuild 1280
MD5 86ae7168499a7aed0980b69d04839ea7 files/digest-htmldoc-1.8.19 75
MD5 4fd3b7ec1b30af0be9c2fd4695062c0c files/digest-htmldoc-1.8.20 77
MD5 06678439bd4de915b822ec99aa90b426 files/fonts.diff 353
diff --git a/app-text/htmldoc/htmldoc-1.8.23.ebuild b/app-text/htmldoc/htmldoc-1.8.23.ebuild
index 6ea77fe55f31..e73a742ba5ea 100644
--- a/app-text/htmldoc/htmldoc-1.8.23.ebuild
+++ b/app-text/htmldoc/htmldoc-1.8.23.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/htmldoc-1.8.23.ebuild,v 1.5 2003/09/15 21:15:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmldoc/htmldoc-1.8.23.ebuild,v 1.6 2003/09/25 17:55:40 mholzer Exp $
DESCRIPTION="Convert HTML pages into a PDF document"
SRC_URI="ftp://ftp.easysw.com/pub/${PN}/${PV}/${P}-source.tar.bz2"
HOMEPAGE="http://www.easysw.com/htmldoc/"
+IUSE="X ssl"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~sparc ~ppc ~alpha"
-DEPEND="virtual/x11"
-RDEPEND=">=dev-libs/openssl-0.9.6e
- >=x11-libs/fltk-1.0.11"
+DEPEND="X? ( virtual/x11 )"
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6e )
+ X? ( >=x11-libs/fltk-1.0.11 )"
src_unpack() {
unpack ${A}
@@ -22,17 +24,17 @@ src_unpack() {
}
src_compile() {
- econf \
- --with-x \
- --with-gui \
- --with-openssl-libs=/usr/lib \
- --with-openssl-includes=/usr/include/openssl
+ local myconf
+ use X && myconf="--with-x --with-gui"
+ use ssl && myconf="${myconf} --with-openssl-libs=/usr/lib \
+ --with-openssl-includes=/usr/include/openssl"
+
+ econf ${myconf}
# Add missing -lfltk_images to LIBS
- sed -i 's/-lfltk /-lfltk -lfltk_images /g' \
- Makedefs || die "failed to detect -lfltk"
+ use X && sed -i 's/-lfltk /-lfltk -lfltk_images /g' Makedefs
- make || die
+ make || die "make failed"
}
src_install() {