summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-20 02:42:40 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-20 02:42:40 +0000
commit8c71371394b665d15cd83e31dab0d7f608ba4236 (patch)
tree3cbc7229f2e6723035f93f88ae5b244522ce2db4 /app-text/htmlinc
parentadd gcc-3.4 patch #47189 (diff)
downloadgentoo-2-8c71371394b665d15cd83e31dab0d7f608ba4236.tar.gz
gentoo-2-8c71371394b665d15cd83e31dab0d7f608ba4236.tar.bz2
gentoo-2-8c71371394b665d15cd83e31dab0d7f608ba4236.zip
gcc-3.x fix #43436
Diffstat (limited to 'app-text/htmlinc')
-rw-r--r--app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch48
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1.ebuild13
2 files changed, 56 insertions, 5 deletions
diff --git a/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
index 63a783dfa6e0..eb92c07ff51b 100644
--- a/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
+++ b/app-text/htmlinc/files/htmlinc-gcc3-gentoo.patch
@@ -79,3 +79,51 @@ diff -u htmlinc/stringlist.h htmlinc-1/stringlist.h
private:
Stringlist::iterator getID(Bytevector id);
+diff -Naur htmlinc-old/help.h htmlinc/help.h
+--- htmlinc/help.h 2000-08-08 09:04:28.000000000 -0400
++++ htmlinc-1/help.h 2004-03-01 19:43:43.770233421 -0500
+@@ -4,25 +4,25 @@
+
+ char * helpV[]=
+ {
+-{"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5"},
+-{"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)"},
+-{""},
+-{"Start: "},
+-{" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>"},
+-{""},
+-{"Options:"},
+-{" <include_dir> = Directory of the Includefiles"},
+-{" <htmlfile_i> = HTML-Files in which the includes should be updated"},
+-{""},
+-{"Examples:"},
+-{" 1: htmlinc ~/www/inc/ *.html"},
+-{""},
+-{" 2: cd ~/www"},
+-{" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)"},
+-{" "},
+-{""},
+-{"Report bugs to ulli@meybohm.de."},
+-{""}
++"HTML INCLUDE SYSTEM Version 1.0 beta1 - Compatible to Phase 5",
++"Copyright (C) 2000 , Ulli Meybohm, www.meybohm.de (GNU General Public License)",
++"",
++"Start: ",
++" htmlinc <include_dir> <htmlfile_1> <htmlfile_2> ... <htmlfile_n>",
++"",
++"Options:",
++" <include_dir> = Directory of the Includefiles",
++" <htmlfile_i> = HTML-Files in which the includes should be updated",
++"",
++"Examples:",
++" 1: htmlinc ~/www/inc/ *.html",
++"",
++" 2: cd ~/www",
++" htmlinc inc/ `find * | grep \"\\\\.\"html` (recursive)",
++" ",
++"",
++"Report bugs to ulli@meybohm.de.",
++""
+ };
+
+ int helpC=18;
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
index 29adbf7ca1c3..c75fe6d8b69c 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.9 2004/03/12 09:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.10 2004/04/20 02:42:39 vapier Exp $
+
+inherit eutils
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
-IUSE=""
-KEYWORDS="x86 sparc"
-SLOT="0"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
DEPEND="virtual/glibc"
S=${WORKDIR}/htmlinc
src_unpack() {
unpack ${A}
- patch -p0 < ${FILESDIR}/htmlinc-gcc3-gentoo.patch || die "could not patch"
+ epatch ${FILESDIR}/htmlinc-gcc3-gentoo.patch
}
src_compile() {