summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-07-10 07:10:30 +0000
committerPeter Volkov <pva@gentoo.org>2008-07-10 07:10:30 +0000
commitd5867f30b30bb41344212a91ae9e5f66f30e287f (patch)
treebba5e8a9c14de33b778ac724efd5b1b2e8cffa22 /app-text/hunspell
parentBump torque to 2.3.1, add some fixes from svn for newer gcc's. (diff)
downloadgentoo-2-d5867f30b30bb41344212a91ae9e5f66f30e287f.tar.gz
gentoo-2-d5867f30b30bb41344212a91ae9e5f66f30e287f.tar.bz2
gentoo-2-d5867f30b30bb41344212a91ae9e5f66f30e287f.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-ovz005 i686)
Diffstat (limited to 'app-text/hunspell')
-rw-r--r--app-text/hunspell/ChangeLog7
-rw-r--r--app-text/hunspell/hunspell-1.2.5.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-text/hunspell/ChangeLog b/app-text/hunspell/ChangeLog
index 46e73d3f9f18..43ed9262a848 100644
--- a/app-text/hunspell/ChangeLog
+++ b/app-text/hunspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/hunspell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.41 2008/06/22 12:43:38 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/ChangeLog,v 1.42 2008/07/10 07:10:30 pva Exp $
+
+*hunspell-1.2.5 (10 Jul 2008)
+
+ 10 Jul 2008; Peter Volkov <pva@gentoo.org> +hunspell-1.2.5.ebuild:
+ Version bump.
*hunspell-1.2.4-r1 (22 Jun 2008)
diff --git a/app-text/hunspell/hunspell-1.2.5.ebuild b/app-text/hunspell/hunspell-1.2.5.ebuild
new file mode 100644
index 000000000000..0af14addced0
--- /dev/null
+++ b/app-text/hunspell/hunspell-1.2.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/hunspell/hunspell-1.2.5.ebuild,v 1.1 2008/07/10 07:10:30 pva Exp $
+
+inherit eutils multilib autotools
+
+MY_P=${PN}-${PV/_beta/b}
+
+DESCRIPTION="Hunspell spell checker - an improved replacement for myspell in OOo."
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://hunspell.sourceforge.net/"
+
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE="ncurses nls readline"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )
+ sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream package creates some executables which names are too generic
+ # to be placed in /usr/bin - this patch prefixes them with 'hunspell-'.
+ # It modifies a Makefile.am file, hence eautoreconf.
+ epatch "${FILESDIR}"/${PN}-1.2.2-renameexes.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ # I wanted to put the include files in /usr/include/hunspell
+ # but this means the openoffice build won't find them.
+ econf \
+ $(use_enable nls) \
+ $(use_with ncurses ui) \
+ $(use_with readline readline) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO license.hunspell || die "installing docs failed"
+ # hunspell is derived from myspell
+ dodoc AUTHORS.myspell README.myspell license.myspell || die "installing myspell docs failed"
+}
+
+pkg_postinst() {
+ elog "To use this package you will also need a dictionary."
+ elog "Hunspell uses myspell format dictionaries; find them"
+ elog "in the app-dicts category as myspell-<LANG>."
+}