summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-25 17:06:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-25 17:06:06 +0000
commit0e064239762e06e925b4345d113c88dc8860aff3 (patch)
tree0f5a7b4505d6f8404573524936c187b2444db2ae /app-text/iso-codes
parentSkip testsuite because of interactive shell wrt #477066 by Jeroen Roovers (diff)
downloadgentoo-2-0e064239762e06e925b4345d113c88dc8860aff3.tar.gz
gentoo-2-0e064239762e06e925b4345d113c88dc8860aff3.tar.bz2
gentoo-2-0e064239762e06e925b4345d113c88dc8860aff3.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/ChangeLog7
-rw-r--r--app-text/iso-codes/iso-codes-3.45.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 26e59796a3d2..ccec6b631377 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.145 2013/06/03 20:00:04 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.146 2013/08/25 17:06:06 eva Exp $
+
+*iso-codes-3.45 (25 Aug 2013)
+
+ 25 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> +iso-codes-3.45.ebuild:
+ Version bump.
*iso-codes-3.42 (03 Jun 2013)
diff --git a/app-text/iso-codes/iso-codes-3.45.ebuild b/app-text/iso-codes/iso-codes-3.45.ebuild
new file mode 100644
index 000000000000..24cc1043c5e9
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.45.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.45.ebuild,v 1.1 2013/08/25 17:06:06 eva Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ [[ -z ${LINGUAS} ]] && return
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas} ${NULL}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo} ${NULL}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ || die "sed in ${norm} folder failed"
+ done
+}