summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-10-31 20:33:03 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-10-31 20:33:03 +0000
commit4c9d495486e420d88d79325734aa61da3fb87ace (patch)
tree1a280273e6ae98d15377a53c71088d15e508555b /app-text/iso-codes
parentUpdate warning about removing old installs. (diff)
downloadgentoo-2-4c9d495486e420d88d79325734aa61da3fb87ace.tar.gz
gentoo-2-4c9d495486e420d88d79325734aa61da3fb87ace.tar.bz2
gentoo-2-4c9d495486e420d88d79325734aa61da3fb87ace.zip
use src_compile, fixes #151387
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/ChangeLog7
-rw-r--r--app-text/iso-codes/iso-codes-0.49-r1.ebuild9
-rw-r--r--app-text/iso-codes/iso-codes-0.49.ebuild11
3 files changed, 19 insertions, 8 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index fe7188372280..bc65a1365379 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.21 2006/06/18 14:51:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.22 2006/10/31 20:33:03 allanonjl Exp $
+
+ 31 Oct 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -iso-codes-0.47.ebuild, -iso-codes-0.47-r1.ebuild, iso-codes-0.49.ebuild,
+ iso-codes-0.49-r1.ebuild:
+ use src_compile, fixes #151387
18 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/iso-codes-0.49-bsd-install.patch, iso-codes-0.49-r1.ebuild:
diff --git a/app-text/iso-codes/iso-codes-0.49-r1.ebuild b/app-text/iso-codes/iso-codes-0.49-r1.ebuild
index 5f1314aaa663..0b44b6082dad 100644
--- a/app-text/iso-codes/iso-codes-0.49-r1.ebuild
+++ b/app-text/iso-codes/iso-codes-0.49-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49-r1.ebuild,v 1.4 2006/10/14 21:01:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49-r1.ebuild,v 1.5 2006/10/31 20:33:03 allanonjl Exp $
inherit eutils autotools
@@ -19,7 +19,7 @@ DEPEND="sys-devel/gettext
>=sys-devel/automake-1.9"
src_unpack() {
- unpack ${A}
+ unpack "${A}"
cd "${S}"
# patch to fix up version reporting (bug #118240)
@@ -35,8 +35,11 @@ src_unpack() {
eautomake
}
-src_install() {
+src_compile() {
econf || die "configure failed"
+}
+
+src_install() {
make DESTDIR="${D}" install || die "Installation failed"
dodoc ChangeLog README TODO
diff --git a/app-text/iso-codes/iso-codes-0.49.ebuild b/app-text/iso-codes/iso-codes-0.49.ebuild
index 3c45a9d00c69..3c4772897bfe 100644
--- a/app-text/iso-codes/iso-codes-0.49.ebuild
+++ b/app-text/iso-codes/iso-codes-0.49.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49.ebuild,v 1.12 2006/10/14 21:01:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49.ebuild,v 1.13 2006/10/31 20:33:03 allanonjl Exp $
inherit autotools
@@ -19,16 +19,19 @@ DEPEND="sys-devel/gettext
>=sys-devel/automake-1.9"
src_unpack() {
- unpack ${A}
- cd ${S}
+ unpack "${A}"
+ cd "${S}"
sed -i -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' Makefile.am
eaclocal
eautoconf
eautomake
}
-src_install() {
+src_compile() {
econf || die "configure failed"
+}
+
+src_install() {
make DESTDIR="${D}" install || die "Installation failed"
dodoc ChangeLog README TODO