summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-06 17:11:14 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-06 17:11:14 +0000
commit33585dac66c640bea476645f8331a4e445309e6f (patch)
treee30be0b978cbf845cbfe01848cf4ebed0ea939bd /app-text/ispell
parentAdd prefix keywords, -liconv on Darwin (diff)
downloadgentoo-2-33585dac66c640bea476645f8331a4e445309e6f.tar.gz
gentoo-2-33585dac66c640bea476645f8331a4e445309e6f.tar.bz2
gentoo-2-33585dac66c640bea476645f8331a4e445309e6f.zip
Bump to EAPI=3, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-text/ispell')
-rw-r--r--app-text/ispell/ChangeLog7
-rw-r--r--app-text/ispell/ispell-3.3.02-r1.ebuild24
2 files changed, 18 insertions, 13 deletions
diff --git a/app-text/ispell/ChangeLog b/app-text/ispell/ChangeLog
index 72134ade76c4..fecbf38b3bfe 100644
--- a/app-text/ispell/ChangeLog
+++ b/app-text/ispell/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/ispell
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.43 2009/12/26 16:27:35 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.44 2010/04/06 17:11:14 abcd Exp $
+
+ 06 Apr 2010; Jonathan Callen <abcd@gentoo.org> ispell-3.3.02-r1.ebuild:
+ Bump to EAPI=3, add prefix keywords
26 Dec 2009; Raúl Porcel <armin76@gentoo.org> ispell-3.3.02-r1.ebuild:
sparc stable wrt #289337
diff --git a/app-text/ispell/ispell-3.3.02-r1.ebuild b/app-text/ispell/ispell-3.3.02-r1.ebuild
index b87a3624cc8f..846da0449e09 100644
--- a/app-text/ispell/ispell-3.3.02-r1.ebuild
+++ b/app-text/ispell/ispell-3.3.02-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02-r1.ebuild,v 1.8 2009/12/26 16:27:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02-r1.ebuild,v 1.9 2010/04/06 17:11:14 abcd Exp $
+
+EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -12,16 +14,14 @@ SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
RDEPEND="sys-apps/miscfiles
>=sys-libs/ncurses-5.2"
DEPEND="${RDEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${WORKDIR}"/${P}-gentoo-${PATCH_VER}.diff
epatch "${FILESDIR}"/${P}-glibc-2.10.patch
@@ -30,16 +30,18 @@ src_unpack() {
sed -e "s:\(^#define CFLAGS\).*:\1 \"${CFLAGS}\":" -i config.X || die
}
-src_compile() {
+src_configure() {
# Prepare config.sh for installation phase to avoid twice rebuild
emake -j1 config.sh || die "configuration failed"
sed \
- -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
- -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
- -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
- -e "s:^\(MAN45DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(BINDIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${ED}\2:" \
+ -e "s:^\(MAN45DIR='\)\(.*\):\1${ED}\2:" \
< config.sh > config.sh.install
+}
+src_compile() {
emake -j1 || die "compilation failed"
}