summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-08 02:26:02 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-08 02:26:02 +0000
commita3676980ec00aad3c41a645072e56721302a0b80 (patch)
tree8d62b45d6f40b057ce669e36f1e055eabd1e8308 /app-text/libspectre
parentVersion bump and added missing file for test (diff)
downloadgentoo-2-a3676980ec00aad3c41a645072e56721302a0b80.tar.gz
gentoo-2-a3676980ec00aad3c41a645072e56721302a0b80.tar.bz2
gentoo-2-a3676980ec00aad3c41a645072e56721302a0b80.zip
Add prefix keywords, patch for Interix
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-text/libspectre')
-rw-r--r--app-text/libspectre/ChangeLog8
-rw-r--r--app-text/libspectre/files/libspectre-0.2.0-interix.patch29
-rw-r--r--app-text/libspectre/libspectre-0.2.3.ebuild14
3 files changed, 44 insertions, 7 deletions
diff --git a/app-text/libspectre/ChangeLog b/app-text/libspectre/ChangeLog
index 78a19cea56da..33b77be83715 100644
--- a/app-text/libspectre/ChangeLog
+++ b/app-text/libspectre/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/libspectre
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/ChangeLog,v 1.31 2009/11/03 18:36:47 tgurr Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/ChangeLog,v 1.32 2010/01/08 02:26:01 abcd Exp $
+
+ 08 Jan 2010; Jonathan Callen <abcd@gentoo.org>
+ +files/libspectre-0.2.0-interix.patch, libspectre-0.2.3.ebuild:
+ Add prefix keywords, patch for Interix
*libspectre-0.2.3 (03 Nov 2009)
diff --git a/app-text/libspectre/files/libspectre-0.2.0-interix.patch b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
new file mode 100644
index 000000000000..7b607542dfad
--- /dev/null
+++ b/app-text/libspectre/files/libspectre-0.2.0-interix.patch
@@ -0,0 +1,29 @@
+diff -ru libspectre-0.2.0.orig/libspectre/spectre-utils.c libspectre-0.2.0/libspectre/spectre-utils.c
+--- libspectre-0.2.0.orig/libspectre/spectre-utils.c 2008-05-06 08:35:07 +0200
++++ libspectre-0.2.0/libspectre/spectre-utils.c 2008-05-06 08:49:51 +0200
+@@ -148,6 +148,17 @@
+ spectre_strdup_vprintf (const char *format,
+ va_list args)
+ {
++#ifdef __INTERIX
++ /* no [v]asprintf here, so we need to do something else. */
++ char * string = NULL;
++ char buf[524288];
++
++ if(vsprintf(buf, format, args) < 0)
++ return NULL;
++
++ string = strdup(buf);
++ return string;
++#else
+ char *string = NULL;
+ int len = vasprintf (&string, format, args);
+
+@@ -155,6 +166,7 @@
+ string = NULL;
+
+ return string;
++#endif
+ }
+
+ char *
diff --git a/app-text/libspectre/libspectre-0.2.3.ebuild b/app-text/libspectre/libspectre-0.2.3.ebuild
index 86075689cc57..d7fa8a2bf6c6 100644
--- a/app-text/libspectre/libspectre-0.2.3.ebuild
+++ b/app-text/libspectre/libspectre-0.2.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/libspectre-0.2.3.ebuild,v 1.1 2009/11/03 18:36:47 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libspectre/libspectre-0.2.3.ebuild,v 1.2 2010/01/08 02:26:01 abcd Exp $
-inherit libtool
+inherit autotools eutils
DESCRIPTION="Library to render Postscript documents."
HOMEPAGE="http://libspectre.freedesktop.org/wiki/"
@@ -10,7 +10,7 @@ SRC_URI="http://libspectre.freedesktop.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
SLOT="0"
IUSE="debug doc test"
@@ -22,7 +22,11 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- elibtoolize
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-0.2.0-interix.patch
+
+ eautoreconf # need new libtool for interix
}
src_compile() {