summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-12-08 17:29:13 +0000
committerAron Griffis <agriffis@gentoo.org>2005-12-08 17:29:13 +0000
commit63fa4d550f44be72db47b5ff40a371901ab542da (patch)
tree9d379917d543f78a8eb062d8d8146d62f0ac177d /app-text/nopaste
parentInitial release. (diff)
downloadgentoo-2-63fa4d550f44be72db47b5ff40a371901ab542da.tar.gz
gentoo-2-63fa4d550f44be72db47b5ff40a371901ab542da.tar.bz2
gentoo-2-63fa4d550f44be72db47b5ff40a371901ab542da.zip
Add new ebuild for nopaste, a command-line interface to rafb.net/paste
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-text/nopaste')
-rw-r--r--app-text/nopaste/ChangeLog10
-rw-r--r--app-text/nopaste/Manifest2
-rw-r--r--app-text/nopaste/files/digest-nopaste-12521
-rw-r--r--app-text/nopaste/metadata.xml9
-rw-r--r--app-text/nopaste/nopaste-1252.ebuild23
5 files changed, 45 insertions, 0 deletions
diff --git a/app-text/nopaste/ChangeLog b/app-text/nopaste/ChangeLog
new file mode 100644
index 000000000000..b78145a5fb89
--- /dev/null
+++ b/app-text/nopaste/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/nopaste
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nopaste/ChangeLog,v 1.1 2005/12/08 17:29:13 agriffis Exp $
+
+*nopaste-1252 (08 Dec 2005)
+
+ 08 Dec 2005; Aron Griffis <agriffis@gentoo.org> +metadata.xml,
+ +nopaste-1252.ebuild:
+ Add new ebuild for nopaste, a command-line interface to rafb.net/paste
+
diff --git a/app-text/nopaste/Manifest b/app-text/nopaste/Manifest
new file mode 100644
index 000000000000..c9b3a962791a
--- /dev/null
+++ b/app-text/nopaste/Manifest
@@ -0,0 +1,2 @@
+MD5 80f1235d613876276df588c91de8d653 files/digest-nopaste-1252 55
+MD5 fe5248ce952dfe78ca41d3a222aa3730 nopaste-1252.ebuild 569
diff --git a/app-text/nopaste/files/digest-nopaste-1252 b/app-text/nopaste/files/digest-nopaste-1252
new file mode 100644
index 000000000000..8094119534f8
--- /dev/null
+++ b/app-text/nopaste/files/digest-nopaste-1252
@@ -0,0 +1 @@
+MD5 2cf3d4ad54200fa65bd92a00af84e67d nopaste-1252 2462
diff --git a/app-text/nopaste/metadata.xml b/app-text/nopaste/metadata.xml
new file mode 100644
index 000000000000..242de99115c9
--- /dev/null
+++ b/app-text/nopaste/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>agriffis@gentoo.org</email>
+ <name>Aron Griffis</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-text/nopaste/nopaste-1252.ebuild b/app-text/nopaste/nopaste-1252.ebuild
new file mode 100644
index 000000000000..66ba71d06747
--- /dev/null
+++ b/app-text/nopaste/nopaste-1252.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nopaste/nopaste-1252.ebuild,v 1.1 2005/12/08 17:29:13 agriffis Exp $
+
+DESCRIPTION="command-line interface to rafb.net/paste"
+HOMEPAGE="http://gentoo.org/~agriffis/nopaste/"
+SRC_URI="${HOMEPAGE}/${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-lang/ruby
+ X? ( || ( x11-misc/xclip x11-misc/xcut ) )"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${DISTDIR}/${P} ${PN}
+}