summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-27 19:21:40 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-27 19:21:40 +0000
commit428b54c216b1d1a5ea87b6f50944d3c9f0781e14 (patch)
tree1d957e91a5074afc2a0c7ad12dfd76734818c291 /app-text/notecase
parentold ebuilds using bindnow-flags (diff)
downloadgentoo-2-428b54c216b1d1a5ea87b6f50944d3c9f0781e14.tar.gz
gentoo-2-428b54c216b1d1a5ea87b6f50944d3c9f0781e14.tar.bz2
gentoo-2-428b54c216b1d1a5ea87b6f50944d3c9f0781e14.zip
Fix building with GCC 4.4. (bug #276188 by the diegobot)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/notecase')
-rw-r--r--app-text/notecase/ChangeLog8
-rw-r--r--app-text/notecase/files/notecase-1.9.8-gcc44.patch22
-rw-r--r--app-text/notecase/notecase-1.9.8.ebuild5
3 files changed, 31 insertions, 4 deletions
diff --git a/app-text/notecase/ChangeLog b/app-text/notecase/ChangeLog
index 96bd604041be..6c250589c88f 100644
--- a/app-text/notecase/ChangeLog
+++ b/app-text/notecase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/notecase
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.23 2008/12/12 12:12:18 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.24 2009/07/27 19:21:40 dirtyepic Exp $
+
+ 27 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> notecase-1.9.8.ebuild,
+ +files/notecase-1.9.8-gcc44.patch:
+ Fix building with GCC 4.4. (bug #276188 by the diegobot)
*notecase-1.9.8 (12 Dec 2008)
diff --git a/app-text/notecase/files/notecase-1.9.8-gcc44.patch b/app-text/notecase/files/notecase-1.9.8-gcc44.patch
new file mode 100644
index 000000000000..be34074283f4
--- /dev/null
+++ b/app-text/notecase/files/notecase-1.9.8-gcc44.patch
@@ -0,0 +1,22 @@
+diff -Naurp notecase-1.9.8-orig/src/lib/IniFile.cpp notecase-1.9.8/src/lib/IniFile.cpp
+--- notecase-1.9.8-orig/src/lib/IniFile.cpp 2008-10-24 12:54:50.000000000 -0600
++++ notecase-1.9.8/src/lib/IniFile.cpp 2009-07-27 13:04:34.519339275 -0600
+@@ -9,6 +9,7 @@
+ #include "IniFile.h"
+ #include <algorithm> //find() function
+ #include <string>
++#include <cstdio>
+ #include "File64.h"
+ #include "FilePath.h"
+ #include "debug.h"
+diff -Naurp notecase-1.9.8-orig/src/_unx/ExecuteFile.cpp notecase-1.9.8/src/_unx/ExecuteFile.cpp
+--- notecase-1.9.8-orig/src/_unx/ExecuteFile.cpp 2008-10-24 12:54:50.000000000 -0600
++++ notecase-1.9.8/src/_unx/ExecuteFile.cpp 2009-07-27 13:07:56.101813217 -0600
+@@ -12,6 +12,7 @@
+ #include "../lib/debug.h"
+ #include <string>
+ #include <cstring>
++#include <cstdio>
+ #include <vector>
+ #include <algorithm>
+ #include <string.h>
diff --git a/app-text/notecase/notecase-1.9.8.ebuild b/app-text/notecase/notecase-1.9.8.ebuild
index ba723a6b76bf..edd283b0c2c5 100644
--- a/app-text/notecase/notecase-1.9.8.ebuild
+++ b/app-text/notecase/notecase-1.9.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.9.8.ebuild,v 1.1 2008/12/12 12:12:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.9.8.ebuild,v 1.2 2009/07/27 19:21:40 dirtyepic Exp $
inherit eutils fdo-mime
@@ -28,6 +28,7 @@ src_unpack() {
# Respect CFLAGS and don't use --as-needed by default
epatch "${FILESDIR}/notecase-1.7.2-CFLAGS.patch"
+ epatch "${FILESDIR}"/${P}-gcc44.patch
if ! use gnome; then
# Comment variable in the Makefile if we don't have gnome