summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-11-05 14:38:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-11-05 14:38:46 +0000
commit0f580330b6a9e2c79992841d0831d39219e1689c (patch)
treeb24b1579520cf0a295a0d577750aa2614618b48d /app-text/odt2txt
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-0f580330b6a9e2c79992841d0831d39219e1689c.tar.gz
gentoo-2-0f580330b6a9e2c79992841d0831d39219e1689c.tar.bz2
gentoo-2-0f580330b6a9e2c79992841d0831d39219e1689c.zip
Moved from sunrise overlay. Bug #263574
(Portage version: 2.2.0_alpha3_p8/cvs/Linux x86_64)
Diffstat (limited to 'app-text/odt2txt')
-rw-r--r--app-text/odt2txt/ChangeLog11
-rw-r--r--app-text/odt2txt/files/odt2txt-0.4-darwin_iconv.patch14
-rw-r--r--app-text/odt2txt/metadata.xml18
-rw-r--r--app-text/odt2txt/odt2txt-0.4.ebuild30
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/odt2txt/ChangeLog b/app-text/odt2txt/ChangeLog
new file mode 100644
index 000000000000..ca6a792ff977
--- /dev/null
+++ b/app-text/odt2txt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/odt2txt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/odt2txt/ChangeLog,v 1.1 2010/11/05 14:38:46 hwoarang Exp $
+
+*odt2txt-0.4 (05 Nov 2010)
+
+ 05 Nov 2010; Markos Chandras <hwoarang@gentoo.org> +odt2txt-0.4.ebuild,
+ +files/odt2txt-0.4-darwin_iconv.patch, +metadata.xml:
+ Moved from sunrise overlay. Bug #263574. Thanks to Dirk Tilger
+ <dirk@miriup.de> for the initial ebuild. Montjoie will be proxy maintainer
+
diff --git a/app-text/odt2txt/files/odt2txt-0.4-darwin_iconv.patch b/app-text/odt2txt/files/odt2txt-0.4-darwin_iconv.patch
new file mode 100644
index 000000000000..05957269888e
--- /dev/null
+++ b/app-text/odt2txt/files/odt2txt-0.4-darwin_iconv.patch
@@ -0,0 +1,14 @@
+diff -ur odt2txt-0.4/Makefile odt2txt-0.4/Makefile
+--- odt2txt-0.4/Makefile 2008-06-23 23:32:28 +0400
++++ odt2txt-0.4/Makefile 2010-05-24 15:39:16 +0400
+@@ -56,6 +56,9 @@
+ CFLAGS += -I$(ZLIB_DIR)
+ LIBS = $(ZLIB_DIR)/libz.a
+ endif
++ifeq ($(UNAME_S),Darwin)
++ LIBS += -liconv
++endif
+ ifeq ($(UNAME_O),Cygwin)
+ CFLAGS += -DICONV_CHAR="const char"
+ LIBS += -liconv
+
diff --git a/app-text/odt2txt/metadata.xml b/app-text/odt2txt/metadata.xml
new file mode 100644
index 000000000000..0ce78691cdf7
--- /dev/null
+++ b/app-text/odt2txt/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer>
+<email>corentin.labbe@geomatys.fr</email>
+<name>LABBE Corentin (Montjoie)</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-text/odt2txt/odt2txt-0.4.ebuild b/app-text/odt2txt/odt2txt-0.4.ebuild
new file mode 100644
index 000000000000..3cb8957d1e5c
--- /dev/null
+++ b/app-text/odt2txt/odt2txt-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/odt2txt/odt2txt-0.4.ebuild,v 1.1 2010/11/05 14:38:46 hwoarang Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A simple converter from OpenDocument Text to plain text"
+HOMEPAGE="http://stosberg.net/odt2txt/"
+SRC_URI="http://stosberg.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ virtual/libiconv"
+DEPEND="sys-apps/groff
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin_iconv.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr || die
+ doman odt2txt.1 || die
+}