summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-09-11 19:29:04 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-09-11 19:29:04 +0000
commit0ff077a0ac76671d4c6fe55be9d6f8fa7618873a (patch)
tree50caa445e6297234c4778e27988c815dbed319a7 /app-text/openjade
parentDrop hardcoded lua version. (diff)
downloadgentoo-2-0ff077a0ac76671d4c6fe55be9d6f8fa7618873a.tar.gz
gentoo-2-0ff077a0ac76671d4c6fe55be9d6f8fa7618873a.tar.bz2
gentoo-2-0ff077a0ac76671d4c6fe55be9d6f8fa7618873a.zip
added prefix support
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-text/openjade')
-rw-r--r--app-text/openjade/ChangeLog8
-rw-r--r--app-text/openjade/files/openjade-1.3.2-darwin.patch41
-rw-r--r--app-text/openjade/openjade-1.3.2-r6.ebuild116
3 files changed, 164 insertions, 1 deletions
diff --git a/app-text/openjade/ChangeLog b/app-text/openjade/ChangeLog
index c4a853fb316d..0bab71bac9d8 100644
--- a/app-text/openjade/ChangeLog
+++ b/app-text/openjade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/openjade
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.74 2013/07/21 10:07:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/ChangeLog,v 1.75 2013/09/11 19:29:04 ottxor Exp $
+
+*openjade-1.3.2-r6 (11 Sep 2013)
+
+ 11 Sep 2013; Christoph Junghans <ottxor@gentoo.org>
+ +files/openjade-1.3.2-darwin.patch, +openjade-1.3.2-r6.ebuild:
+ added prefix support
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> -openjade-1.3.2-r4.ebuild,
metadata.xml:
diff --git a/app-text/openjade/files/openjade-1.3.2-darwin.patch b/app-text/openjade/files/openjade-1.3.2-darwin.patch
new file mode 100644
index 000000000000..524454860d80
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-darwin.patch
@@ -0,0 +1,41 @@
+See also http://finkproject.org/doc/porting/libtool.php
+(Section 3.3) Fixing 1.4.x (Subsection 1) The flat_namespace bug
+--- configure~ 2007-10-08 01:55:00 +0200
++++ configure 2007-10-08 01:55:27 +0200
+@@ -3063,9 +3063,6 @@
+
+
+ case "${host}" in
+- *-*-darwin*)
+- LINKFLAGS="-no-undefined"
+- ;;
+ *)
+ if test "$GXX"
+ then
+@@ -7907,7 +7904,7 @@
+ ;;
+
+ darwin* | rhapsody*)
+- allow_undefined_flag='-undefined suppress'
++ allow_undefined_flag='-undefined suppress -flat_namespace'
+ # FIXME: Relying on posixy $() will cause problems for
+ # cross-compilation, but unfortunately the echo tests do not
+ # yet detect zsh echo's removal of \ escapes.
+--- config/ltmain.sh~ 2002-01-17 14:45:52 +0100
++++ config/ltmain.sh 2007-10-08 03:08:26 +0200
+@@ -3913,10 +3913,15 @@
+
+ # Directory that this library needs to be installed in:
+ libdir='$install_libdir'"
++case "${host}" in
++ *-*-darwin*)
++ ;;
++ *)
+ if test "$installed" = no && test $need_relink = yes; then
+ $echo >> $output "\
+ relink_command=\"$relink_command\""
+ fi
++esac
+ done
+ fi
+
diff --git a/app-text/openjade/openjade-1.3.2-r6.ebuild b/app-text/openjade/openjade-1.3.2-r6.ebuild
new file mode 100644
index 000000000000..3b525beda710
--- /dev/null
+++ b/app-text/openjade/openjade-1.3.2-r6.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r6.ebuild,v 1.1 2013/09/11 19:29:04 ottxor Exp $
+
+EAPI=5
+
+inherit autotools sgml-catalog eutils flag-o-matic multilib
+
+DESCRIPTION="Jade is an implementation of DSSSL - an ISO standard for formatting SGML and XML documents"
+HOMEPAGE="http://openjade.sourceforge.net"
+SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="app-text/sgml-common
+ >=app-text/opensp-1.5.1"
+DEPEND="dev-lang/perl
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-deplibs.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-msggen.pl.patch
+ epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+ epatch "${FILESDIR}"/${P}-libosp-la.patch
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ epatch "${FILESDIR}"/${P}-darwin.patch
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
+
+ ln -s config/configure.in configure.ac || die
+ cp "${FILESDIR}"/${P}-acinclude.m4 acinclude.m4 || die
+ rm config/missing || die
+
+ AT_NOEAUTOMAKE=yes
+ eautoreconf
+
+ SGML_PREFIX="${EPREFIX}"/usr/share/sgml
+}
+
+src_configure() {
+ # We need Prefix env, bug #287358
+ export CONFIG_SHELL="${CONFIG_SHELL:-${BASH}}"
+ econf \
+ --enable-http \
+ --enable-default-catalog="${EPREFIX}"/etc/sgml/catalog \
+ --enable-default-search-path="${EPREFIX}"/usr/share/sgml \
+ --enable-splibdir="${EPREFIX}"/usr/$(get_libdir) \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --datadir="${EPREFIX}"/usr/share/sgml/${P} \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Bug 412725.
+ unset INCLUDE
+
+ emake -j1 SHELL="${BASH}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+
+ make DESTDIR="${D}" \
+ SHELL="${BASH}" \
+ libdir="${EPREFIX}"/usr/$(get_libdir) \
+ install install-man
+
+ prune_libtool_files
+
+ dosym openjade /usr/bin/jade
+ dosym onsgmls /usr/bin/nsgmls
+ dosym osgmlnorm /usr/bin/sgmlnorm
+ dosym ospam /usr/bin/spam
+ dosym ospent /usr/bin/spent
+ dosym osx /usr/bin/sgml2xml
+
+ insinto /usr/share/sgml/${P}/
+ doins dsssl/builtins.dsl
+
+ echo 'SYSTEM "builtins.dsl" "builtins.dsl"' > ${ED}/usr/share/sgml/${P}/catalog
+ insinto /usr/share/sgml/${P}/dsssl
+ doins dsssl/{dsssl.dtd,style-sheet.dtd,fot.dtd}
+ newins "${FILESDIR}"/${P}.dsssl-catalog catalog
+# Breaks sgml2xml among other things
+# insinto /usr/share/sgml/${P}/unicode
+# doins unicode/{catalog,unicode.sd,unicode.syn,gensyntax.pl}
+ insinto /usr/share/sgml/${P}/pubtext
+ doins pubtext/*
+
+ dodoc NEWS README VERSION
+ dohtml doc/*.htm
+
+ insinto /usr/share/doc/${PF}/jadedoc
+ doins jadedoc/*.htm
+ insinto /usr/share/doc/${PF}/jadedoc/images
+ doins jadedoc/images/*
+}
+
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
+ "/usr/share/sgml/openjade-${PV}/dsssl/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/${P}.cat"