summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-10-31 10:37:45 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-10-31 10:37:45 +0000
commit8fc69d957a139f719da9d5310916560a80764001 (patch)
treeafdd2d477f83966760e6690bedaf32dae6968a70 /app-text/opensp
parentMisc. clean-ups in ebuild. (diff)
downloadgentoo-2-8fc69d957a139f719da9d5310916560a80764001.tar.gz
gentoo-2-8fc69d957a139f719da9d5310916560a80764001.tar.bz2
gentoo-2-8fc69d957a139f719da9d5310916560a80764001.zip
Use the same filters as openjade (bug #100828). Removing old ebuild/patch.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-text/opensp')
-rw-r--r--app-text/opensp/ChangeLog5
-rw-r--r--app-text/opensp/files/digest-opensp-1.5-r11
-rw-r--r--app-text/opensp/files/opensp-1.5-gcc33.patch64
-rw-r--r--app-text/opensp/opensp-1.5-r1.ebuild50
-rw-r--r--app-text/opensp/opensp-1.5.1.ebuild25
5 files changed, 23 insertions, 122 deletions
diff --git a/app-text/opensp/ChangeLog b/app-text/opensp/ChangeLog
index 131c59b466ad..0f5e4c8280f2 100644
--- a/app-text/opensp/ChangeLog
+++ b/app-text/opensp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/opensp
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/ChangeLog,v 1.26 2005/10/10 06:54:43 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/ChangeLog,v 1.27 2005/10/31 10:37:45 leonardop Exp $
+
+ 31 Oct 2005; Leonardo Boshell <leonardop@gentoo.org> opensp-1.5.1.ebuild:
+ Use the same CFLAGS filters from openjade to avoid obscure bugs (bug #100828).
10 Oct 2005; Hardave Riar <hardave@gentoo.org> opensp-1.5.1.ebuild:
Stable on mips.
diff --git a/app-text/opensp/files/digest-opensp-1.5-r1 b/app-text/opensp/files/digest-opensp-1.5-r1
deleted file mode 100644
index c350491b1dc9..000000000000
--- a/app-text/opensp/files/digest-opensp-1.5-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 87f56e79ae0c20397f4207d61d154303 OpenSP-1.5.tar.gz 1288057
diff --git a/app-text/opensp/files/opensp-1.5-gcc33.patch b/app-text/opensp/files/opensp-1.5-gcc33.patch
deleted file mode 100644
index fdca70614137..000000000000
--- a/app-text/opensp/files/opensp-1.5-gcc33.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- include/Attribute.h.gcc33 2003-05-22 17:04:20.000000000 +0100
-+++ include/Attribute.h 2003-05-22 17:04:48.000000000 +0100
-@@ -25,12 +25,32 @@
- class Entity;
- class Notation;
- class DeclaredValue;
--class AttributeValue;
- class TokenizedAttributeValue;
- class AttributeSemantics;
- class AttributeContext;
- class Syntax;
-
-+class SP_API AttributeValue : public Resource {
-+public:
-+ enum Type {
-+ implied,
-+ cdata,
-+ tokenized
-+ };
-+ AttributeValue();
-+ virtual ~AttributeValue();
-+ virtual AttributeSemantics *makeSemantics(const DeclaredValue *,
-+ AttributeContext &,
-+ const StringC &,
-+ unsigned &,
-+ unsigned &) const;
-+ virtual Type info(const Text *&, const StringC *&) const = 0;
-+ virtual const Text *text() const;
-+ virtual Boolean recoverUnquoted(const StringC &, const Location &,
-+ AttributeContext &, const StringC &);
-+ static Boolean handleAsUnterminated(const Text &, AttributeContext &);
-+};
-+
- class SP_API AttributeDefinitionDesc {
- public:
- AttributeDefinitionDesc() { }
-@@ -380,27 +400,6 @@
- ConstPtr<Notation> notation_;
- };
-
--class SP_API AttributeValue : public Resource {
--public:
-- enum Type {
-- implied,
-- cdata,
-- tokenized
-- };
-- AttributeValue();
-- virtual ~AttributeValue();
-- virtual AttributeSemantics *makeSemantics(const DeclaredValue *,
-- AttributeContext &,
-- const StringC &,
-- unsigned &,
-- unsigned &) const;
-- virtual Type info(const Text *&, const StringC *&) const = 0;
-- virtual const Text *text() const;
-- virtual Boolean recoverUnquoted(const StringC &, const Location &,
-- AttributeContext &, const StringC &);
-- static Boolean handleAsUnterminated(const Text &, AttributeContext &);
--};
--
- class SP_API ImpliedAttributeValue : public AttributeValue {
- public:
- ImpliedAttributeValue();
diff --git a/app-text/opensp/opensp-1.5-r1.ebuild b/app-text/opensp/opensp-1.5-r1.ebuild
deleted file mode 100644
index 4786ddca54ea..000000000000
--- a/app-text/opensp/opensp-1.5-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5-r1.ebuild,v 1.26 2005/07/06 09:59:15 liquidx Exp $
-
-inherit eutils gnuconfig flag-o-matic
-
-MY_P=${P/opensp/OpenSP}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="A free, object-oriented toolkit for SGML parsing and entity management"
-HOMEPAGE="http://openjade.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openjade/${MY_P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390 ppc64"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-PDEPEND=">=app-text/openjade-1.3.2"
-
-# Note: openjade is in PDEPEND because starting from openjade-1.3.2, opensp
-# has been SPLIT from openjade into its own package. Hence if you
-# install this, you need to upgrade to a new openjade as well.
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # from gentoo bug #21631 and
- # http://sourceforge.net/tracker/index.php?func=detail&aid=742214&group_id=2115&atid=302115
- epatch ${FILESDIR}/${P}-gcc33.patch
- epatch ${FILESDIR}/${P}-gcc34.patch
-}
-
-src_compile() {
- local myconf
- # bug #77033
- filter-flags "-fvisibility=hidden"
- # Detect mips systems properly
- gnuconfig_update
-
- myconf="${myconf} --enable-default-catalog=/etc/sgml/catalog"
- myconf="${myconf} --enable-default-search-path=/usr/share/sgml"
- myconf="${myconf} --datadir=/usr/share/sgml/${P}"
- econf ${myconf} $(use_enable nls) || die "econf failed"
- emake pkgdocdir=/usr/share/doc/${PF} || die "parallel make failed"
-}
-
-src_install() {
- make DESTDIR=${D} pkgdocdir=/usr/share/doc/${PF} install || die
-}
diff --git a/app-text/opensp/opensp-1.5.1.ebuild b/app-text/opensp/opensp-1.5.1.ebuild
index ae277e8f6913..7ea040e30805 100644
--- a/app-text/opensp/opensp-1.5.1.ebuild
+++ b/app-text/opensp/opensp-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.1.ebuild,v 1.10 2005/10/10 06:54:43 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/opensp/opensp-1.5.1.ebuild,v 1.11 2005/10/31 10:37:45 leonardop Exp $
inherit eutils flag-o-matic
@@ -22,15 +22,28 @@ PDEPEND=">=app-text/openjade-1.3.2"
# has been SPLIT from openjade into its own package. Hence if you
# install this, you need to upgrade to a new openjade as well.
+
src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.5-gcc34.patch
+ unpack "${A}"
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5-gcc34.patch
}
src_compile() {
- # gentoo bug #77033
- filter-flags "-fvisibility=hidden"
+ #
+ # The following filters are taken from openjade's ebuild. See bug #100828.
+ #
+
+ # Please note! Opts are disabled. If you know what you're doing
+ # feel free to remove this line. It may cause problems with
+ # docbook-sgml-utils among other things.
+ ALLOWED_FLAGS="-O -O1 -O2 -pipe -g -march"
+ strip-flags
+
+ # Default CFLAGS and CXXFLAGS is -O2 but this make openjade segfault
+ # on hppa. Using -O1 works fine. So I force it here.
+ use hppa && replace-flags -O2 -O1
myconf="--enable-http"
myconf="${myconf} --enable-default-catalog=/etc/sgml/catalog"