summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-12-26 21:44:37 +0000
committerVlastimil Babka <caster@gentoo.org>2008-12-26 21:44:37 +0000
commit6be425b3d4c8cebf3871d6fc57b3dc12a34cf6f3 (patch)
treef15d59a0cf25968f710034a5a7aa5631c2001e06 /app-text/pdftk
parentBump to 3.4.4 (diff)
downloadgentoo-2-6be425b3d4c8cebf3871d6fc57b3dc12a34cf6f3.tar.gz
gentoo-2-6be425b3d4c8cebf3871d6fc57b3dc12a34cf6f3.tar.bz2
gentoo-2-6be425b3d4c8cebf3871d6fc57b3dc12a34cf6f3.zip
Revbump fixing build with gcc 4.3 (bug #225709 and #235645 and #251796) thanks to patch adapted from Debian submitted by <andrex@mail.ee>. Fixes LDFLAGS and man page (bug #209802 and #234832) thanks to Stephan Springer <Gentoo-bugs@Lini.de>. Uses EAPI2 use deps for gcc[gcj] dep.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r1-perfctr x86_64)
Diffstat (limited to 'app-text/pdftk')
-rw-r--r--app-text/pdftk/ChangeLog12
-rw-r--r--app-text/pdftk/files/pdftk-1.41-gcc-4.3.patch203
-rw-r--r--app-text/pdftk/files/pdftk-1.41-honor-ldflags.patch11
-rw-r--r--app-text/pdftk/pdftk-1.41-r1.ebuild43
4 files changed, 268 insertions, 1 deletions
diff --git a/app-text/pdftk/ChangeLog b/app-text/pdftk/ChangeLog
index 2d0dc72dba77..a2ddd6f23770 100644
--- a/app-text/pdftk/ChangeLog
+++ b/app-text/pdftk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-text/pdftk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.26 2008/08/02 07:21:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/ChangeLog,v 1.27 2008/12/26 21:44:37 caster Exp $
+
+*pdftk-1.41-r1 (26 Dec 2008)
+
+ 26 Dec 2008; Vlastimil Babka <caster@gentoo.org>
+ +files/pdftk-1.41-gcc-4.3.patch, +files/pdftk-1.41-honor-ldflags.patch,
+ +pdftk-1.41-r1.ebuild:
+ Revbump fixing build with gcc 4.3 (bug #225709 and #235645 and #251796)
+ thanks to patch adapted from Debian submitted by <andrex@mail.ee>. Fixes
+ LDFLAGS and man page (bug #209802 and #234832) thanks to Stephan Springer
+ <Gentoo-bugs@Lini.de>. Uses EAPI2 use deps for gcc[gcj] dep.
02 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-text/pdftk/files/pdftk-1.41-gcc-4.3.patch b/app-text/pdftk/files/pdftk-1.41-gcc-4.3.patch
new file mode 100644
index 000000000000..be46b0dcbc63
--- /dev/null
+++ b/app-text/pdftk/files/pdftk-1.41-gcc-4.3.patch
@@ -0,0 +1,203 @@
+# posted to bug #251796 by <andrex@mail.ee> from Debian patches
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/bc/asn1/Makefile pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/bc/asn1/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/bc/asn1/Makefile 2008-12-23 00:04:52.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/Makefile pdftk-1.41/java_libs/com/lowagie/text/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/Makefile 2008-12-22 23:58:52.000000000 +0200
+@@ -25,13 +25,12 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+
+-all : $(library) $(headers)
++all : $(library) $(headers) $(classes)
+
+ $(library) : $(objects)
+ $(AR) $(ARFLAGS) $(library) $(objects);
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/markup/Makefile pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/markup/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/markup/Makefile 2008-12-23 00:04:28.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/Makefile 2008-12-23 00:04:11.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/postscript/Makefile 2008-12-23 00:03:05.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/codec/wmf/Makefile 2008-12-23 00:03:29.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/fonts/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/fonts/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/fonts/Makefile 2008-12-23 00:01:33.000000000 +0200
+@@ -34,8 +34,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/Makefile pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/Makefile 2008-12-23 00:00:25.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/pdf/PdfEncryption.java 2008-12-22 23:46:21.000000000 +0200
+@@ -50,7 +50,7 @@
+
+ package com.lowagie.text.pdf;
+
+-import java_local.security.MessageDigest; // ssteward
++import java.security.MessageDigest;
+ import com.lowagie.text.ExceptionConverter;
+
+ /**
+diff -u -r pdftk-1.41.orig/java_libs/com/lowagie/text/xml/xmp/Makefile pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile
+--- pdftk-1.41.orig/java_libs/com/lowagie/text/xml/xmp/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/com/lowagie/text/xml/xmp/Makefile 2008-12-22 23:59:42.000000000 +0200
+@@ -25,8 +25,7 @@
+ # the "$*" automatic variable, here
+ #
+ %.h : %.class
+- $(GCJH) --classpath="." $*;
+- $(RM) $<
++ $(GCJH) --classpath="$(java_libs_root):." $*;
+
+ ##
+ # targets
+diff -u -r pdftk-1.41.orig/java_libs/Makefile pdftk-1.41/java_libs/Makefile
+--- pdftk-1.41.orig/java_libs/Makefile 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/java_libs/Makefile 2008-12-22 23:47:10.000000000 +0200
+@@ -13,13 +13,7 @@
+ # append gcj flags
+ export GCJFLAGS+= --encoding=UTF-8 --classpath="$(java_libs_root)"
+
+-all : libgcj_local itext
+-
+-libgcj_local :
+- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security";
+- $(MAKE) -C "$(java_libs_root)/gnu_local/java/security/provider";
+- $(MAKE) -C "$(java_libs_root)/gnu/gcj/convert";
+- $(MAKE) -C "$(java_libs_root)/java_local/security";
++all : itext
+
+ itext :
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/text";
+@@ -35,13 +29,7 @@
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/bc/asn1";
+ $(MAKE) -C "$(java_libs_root)/com/lowagie/text/pdf/codec/postscript";
+
+-clean : libgcj_local_clean itext_clean
+-
+-libgcj_local_clean :
+- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security" clean;
+- $(MAKE) -iC "$(java_libs_root)/gnu_local/java/security/provider" clean;
+- $(MAKE) -iC "$(java_libs_root)/gnu/gcj/convert" clean;
+- $(MAKE) -iC "$(java_libs_root)/java_local/security" clean;
++clean : itext_clean
+
+ itext_clean :
+ $(MAKE) -iC "$(java_libs_root)/com/lowagie/text" clean;
+diff -u -r pdftk-1.41.orig/pdftk/Makefile.Base pdftk-1.41/pdftk/Makefile.Base
+--- pdftk-1.41.orig/pdftk/Makefile.Base 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/pdftk/Makefile.Base 2008-12-22 23:44:33.000000000 +0200
+@@ -31,18 +31,6 @@
+ afms= $(wildcard $(java_libs_root)/com/lowagie/text/pdf/fonts/*.afm)
+ afm_objects= $(patsubst %.afm, %.o, $(afms))
+
+-# older versions of libgcj might not have the MD5 algorithm,
+-# so I added it here; these *_local java files were grabbed from
+-# libgcj CVS on March 7, 2004; diffed September 5, 2006 w/ gcc 4.1.1
+-#
+-# gnu/gcj/convert/Input_UnicodeBig.java was grabbed March 26, 2004; diffed September 5, 2006 w/ gcc 4.1.1
+-#
+-libgcj_local_libs = \
+-$(java_libs_root)/java_local/security/security.a \
+-$(java_libs_root)/gnu_local/java/security/provider/provider.a \
+-$(java_libs_root)/gnu_local/java/security/security.a \
+-$(java_libs_root)/gnu/gcj/convert/convert.a
+-
+ # this must already be set according to your platform Makefile;
+ # we're just appending to it, here
+ #
+diff -u -r pdftk-1.41.orig/pdftk/Makefile.Generic pdftk-1.41/pdftk/Makefile.Generic
+--- pdftk-1.41.orig/pdftk/Makefile.Generic 2008-12-22 23:43:29.000000000 +0200
++++ pdftk-1.41/pdftk/Makefile.Generic 2008-12-23 00:06:24.000000000 +0200
+@@ -28,7 +28,7 @@
+
+ # itext compiler flags
+ # -O3 might cause pdftk to segfault on cat operation (gcc 3.4.4)
+-export GCJFLAGS= -O2
++export GCJFLAGS= -O2 -w
+
+ #
+ export ARFLAGS= rs
diff --git a/app-text/pdftk/files/pdftk-1.41-honor-ldflags.patch b/app-text/pdftk/files/pdftk-1.41-honor-ldflags.patch
new file mode 100644
index 000000000000..402382557ab0
--- /dev/null
+++ b/app-text/pdftk/files/pdftk-1.41-honor-ldflags.patch
@@ -0,0 +1,11 @@
+--- pdftk-1.41/pdftk/Makefile.Base.orig 2006-10-25 01:44:06.000000000 +0200
++++ pdftk-1.41/pdftk/Makefile.Base 2008-08-15 17:21:18.073275624 +0200
+@@ -63,7 +63,7 @@
+ $(CXX) pdftk.cc -I$(java_libs_root) $(CPPFLAGS) -c
+
+ pdftk : pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects)
+- $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) -o pdftk
++ $(CXX) pdftk.o attachments.o report.o $(itext_libs) $(libgcj_local_libs) $(afm_objects) -I$(java_libs_root) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -o pdftk
+
+ install:
+ /usr/bin/install pdftk /usr/local/bin
diff --git a/app-text/pdftk/pdftk-1.41-r1.ebuild b/app-text/pdftk/pdftk-1.41-r1.ebuild
new file mode 100644
index 000000000000..fe4118daaa67
--- /dev/null
+++ b/app-text/pdftk/pdftk-1.41-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-1.41-r1.ebuild,v 1.1 2008/12/26 21:44:37 caster Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdfhacks.com/pdftk"
+SRC_URI="http://www.pdfhacks.com/pdftk/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=sys-devel/gcc-4.3.1[gcj]"
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ bug #225709 and #251796
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+ bug #209802
+ epatch "${FILESDIR}/${P}-honor-ldflags.patch"
+ # force usage of custom CFLAGS.
+ sed -iorig 's:-O2:\$(CFLAGS):g' "${S}"/Makefile.Generic
+}
+
+src_compile() {
+ # java-config settings break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+ # parallel make fails
+ emake -j1 -f Makefile.Generic || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ newman ../debian/pdftk.1 pdftk.1
+ dohtml ../pdftk.1.html
+}