summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 08:14:08 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 08:14:08 +0000
commit286925b195888e71498cb2526eec2e833cefd3dc (patch)
treeff831a4ac30387f6c09cdcd4bc948f11bf9827fa /app-text/recode/recode-3.6_p17-r2.ebuild
parentStable on amd64 wrt bug #322791 (diff)
downloadgentoo-2-286925b195888e71498cb2526eec2e833cefd3dc.tar.gz
gentoo-2-286925b195888e71498cb2526eec2e833cefd3dc.tar.bz2
gentoo-2-286925b195888e71498cb2526eec2e833cefd3dc.zip
Dropped ppc-macos-new.diff for all non prefix arches, #324519
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/recode/recode-3.6_p17-r2.ebuild')
-rw-r--r--app-text/recode/recode-3.6_p17-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-text/recode/recode-3.6_p17-r2.ebuild b/app-text/recode/recode-3.6_p17-r2.ebuild
new file mode 100644
index 000000000000..57e1bdcd2ae2
--- /dev/null
+++ b/app-text/recode/recode-3.6_p17-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/recode-3.6_p17-r2.ebuild,v 1.1 2010/06/24 08:14:08 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils flag-o-matic libtool toolchain-funcs
+
+MY_P=${P%_*}
+MY_PV=${PV%_*}
+DEB_PATCH=${PV#*p}
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="http://recode.progiciels-bpi.ca/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz
+ mirror://debian/pool/main/r/${PN}/${PN}_${MY_PV}-${DEB_PATCH}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${MY_P}-gettextfix.diff" #239372
+ epatch "${FILESDIR}"/${MY_P}-as-if.patch #283029
+ epatch "${WORKDIR}"/${PN}_${MY_PV}-${DEB_PATCH}.diff
+ sed -i '1i#include <stdlib.h>' src/argmatch.c || die
+
+ # Needed under FreeBSD, too
+ # Needed under Interix too
+ # now replaced by the -new.patch ...
+ # epatch "${FILESDIR}"/${MY_P}-ppc-macos.diff
+ if use x86-fbsd || use x86-interix || use ppc-macos; then
+ epatch "${FILESDIR}"/${MY_P}-ppc-macos-new.diff
+ fi
+ [[ ${CHOST} == *-interix[35]* ]] && epatch "${FILESDIR}"/${PN}-3.6-interix-getopt.patch
+ cp lib/error.c lib/xstrdup.c lib/getopt.c lib/getopt1.c src/ || die "file copy failed"
+
+ # Remove old libtool macros
+ rm "${S}"/acinclude.m4
+
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ tc-export CC LD
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+ # --without-included-gettext means we always use system headers
+ # and library
+ econf --without-included-gettext $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BACKLOG ChangeLog NEWS README THANKS TODO
+ rm -f "${ED}"/usr/lib/charset.alias
+}