summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-13 20:22:37 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-13 20:22:37 +0000
commit92a9d7597190047d28f29a5844b9180ab506425a (patch)
tree7c91a727f0e34a0c3a7aecba5efa2d132e20f472 /app-text/rfcutil
parentStable for AMD64, wrt security bug #394587 (diff)
downloadgentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.tar.gz
gentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.tar.bz2
gentoo-2-92a9d7597190047d28f29a5844b9180ab506425a.zip
Fix building rfc-index by Hartmut Figge, and thanks to Victor for the patch (bug #335152). Clean up old patch.
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'app-text/rfcutil')
-rw-r--r--app-text/rfcutil/ChangeLog9
-rw-r--r--app-text/rfcutil/files/rfc-3.2.3-index.patch17
-rw-r--r--app-text/rfcutil/files/rfc-3.2.3.diff4
-rw-r--r--app-text/rfcutil/rfcutil-3.2.3-r1.ebuild45
4 files changed, 72 insertions, 3 deletions
diff --git a/app-text/rfcutil/ChangeLog b/app-text/rfcutil/ChangeLog
index 89ca9f640b82..460165aff1df 100644
--- a/app-text/rfcutil/ChangeLog
+++ b/app-text/rfcutil/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/rfcutil
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/ChangeLog,v 1.26 2011/07/20 13:52:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/ChangeLog,v 1.27 2011/12/13 20:22:37 jer Exp $
+
+*rfcutil-3.2.3-r1 (13 Dec 2011)
+
+ 13 Dec 2011; Jeroen Roovers <jer@gentoo.org> +rfcutil-3.2.3-r1.ebuild,
+ +files/rfc-3.2.3-index.patch, files/rfc-3.2.3.diff:
+ Fix building rfc-index by Hartmut Figge, and thanks to Victor for the patch
+ (bug #335152). Clean up old patch.
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/app-text/rfcutil/files/rfc-3.2.3-index.patch b/app-text/rfcutil/files/rfc-3.2.3-index.patch
new file mode 100644
index 000000000000..6b4deb607d6a
--- /dev/null
+++ b/app-text/rfcutil/files/rfc-3.2.3-index.patch
@@ -0,0 +1,17 @@
+--- a/rfc-3.2.3/rfc-3.2.3
++++ b/rfc-3.2.3/rfc-3.2.3
+@@ -103,11 +103,12 @@
+ ."It may be desirable to change the\n\$indexpath to a location you can write to.";
+ close (INDEXPATH);
+ $indexlength=numlines($indexpath);
+- print "Modem users one moment, it's about 400k \(doesn't need to be updated often\)\n";
++ print "Modem users one moment, it's about 1024k \(doesn't need to be updated often\)\n";
+ print "original lines \t= $indexlength\t$indexpath\n";
+ #system ("$viewer -dump http://www.faqs.org/rfc/rfc-index.txt > $indexpath");
+ #system ("$viewer -dump http://www.dewn.com/rfc/rfc-index.txt > $indexpath");
+- system ("$viewer -dump http://ftp.isi.edu/in-notes/rfc-index.txt > $indexpath");
++ #system ("$viewer -dump http://ftp.isi.edu/in-notes/rfc-index.txt > $indexpath");
++ system ("$viewer -dump http://www.ietf.org/rfc/rfc-index.txt > $indexpath");
+ $indexlength=numlines($indexpath); print "new lines \t= $indexlength\t$indexpath\n";
+ exit }
+
diff --git a/app-text/rfcutil/files/rfc-3.2.3.diff b/app-text/rfcutil/files/rfc-3.2.3.diff
index 451b6bd476f8..cb7c14e3e376 100644
--- a/app-text/rfcutil/files/rfc-3.2.3.diff
+++ b/app-text/rfcutil/files/rfc-3.2.3.diff
@@ -1,5 +1,5 @@
---- rfc-3.2.3/rfc-3.2.3.orig 2004-03-24 06:07:06.303313504 +0930
-+++ rfc-3.2.3/rfc-3.2.3 2004-03-24 06:08:14.408959872 +0930
+--- a/rfc-3.2.3/rfc-3.2.3
++++ b/rfc-3.2.3/rfc-3.2.3
@@ -36,8 +36,8 @@
# These make it avail for all users if you can't
diff --git a/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild b/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..4ae42a883d16
--- /dev/null
+++ b/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rfcutil/rfcutil-3.2.3-r1.ebuild,v 1.1 2011/12/13 20:22:37 jer Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_PN="rfc"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="return all related RFCs based upon a number or a search string"
+HOMEPAGE="http://www.dewn.com/rfc/"
+SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ || ( www-client/lynx virtual/w3m )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${MY_P}.diff \
+ "${FILESDIR}"/${MY_P}-index.patch
+}
+
+src_install() {
+ newbin ${MY_P} ${MY_PN}
+ doman ${MY_PN}.1
+ dodoc CHANGELOG KNOWN_BUGS README
+ keepdir /var/cache/rfc
+}
+
+pkg_postinst() {
+ elog "Gaarde suggests you make a cron.monthly to run the following:"
+ elog " /usr/bin/rfc -i"
+}
+
+pkg_prerm() {
+ rm -f "${ROOT}"/var/cache/rfc/*
+}