summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-12 19:19:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-12 19:19:40 +0000
commit039523a345970fadea149342add17f7840e09ed9 (patch)
tree97a8fec2720fce5d2c92e1afb2d007b5eaf7708f /app-text/sablotron
parentBrainfart during stabilization for bug #245517, going back to .17 for stable ... (diff)
downloadgentoo-2-039523a345970fadea149342add17f7840e09ed9.tar.gz
gentoo-2-039523a345970fadea149342add17f7840e09ed9.tar.bz2
gentoo-2-039523a345970fadea149342add17f7840e09ed9.zip
Simplify ebuild, make sure eautoreconf is executed during src_unpack rather than compile, remove doc USE flag since it was automagic, remove old workaround that is not useful right now.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/ChangeLog8
-rw-r--r--app-text/sablotron/sablotron-1.0.3.ebuild27
2 files changed, 18 insertions, 17 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index ef7e77258d3e..9c7cdf3d2e1a 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sablotron
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.56 2008/01/25 19:17:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.57 2008/12/12 19:19:40 flameeyes Exp $
+
+ 12 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ sablotron-1.0.3.ebuild:
+ Simplify ebuild, make sure eautoreconf is executed during src_unpack
+ rather than compile, remove doc USE flag since it was automagic, remove
+ old workaround that is not useful right now.
25 Jan 2008; Fabian Groffen <grobian@gentoo.org> sablotron-1.0.1.ebuild,
sablotron-1.0.2.ebuild, sablotron-1.0.3.ebuild:
diff --git a/app-text/sablotron/sablotron-1.0.3.ebuild b/app-text/sablotron/sablotron-1.0.3.ebuild
index b8960cc58fea..b9a06a51e19e 100644
--- a/app-text/sablotron/sablotron-1.0.3.ebuild
+++ b/app-text/sablotron/sablotron-1.0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.3.ebuild,v 1.3 2008/01/25 19:17:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.3.ebuild,v 1.4 2008/12/12 19:19:40 flameeyes Exp $
-inherit base autotools flag-o-matic
+inherit base autotools
MY_PN="Sablot"
MY_P="${MY_PN}-${PV}"
@@ -16,31 +16,28 @@ SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc perl"
+IUSE="perl"
RDEPEND=">=dev-libs/expat-1.95.6-r1"
DEPEND="${RDEPEND}
- doc? ( >=dev-perl/XML-Parser-2.3 )"
+ >=dev-perl/XML-Parser-2.3"
PATCHES="${FILESDIR}/1.0.3-libsablot-expat.patch"
+src_unpack() {
+ base_src_unpack
+
+ eautoreconf
+ elibtoolize
+}
+
src_compile() {
# Don't use --without-html-dir, since that ends up installing files under
# the /no directory
local myconf="--with-html-dir=/usr/share/doc/${PF}/html"
- # Please make sure at least elibtoolize is run, else we get references
- # to PORTAGE_TMPDIR in /usr/lib/libsablot.la ...
- eautoreconf
-
use perl && myconf="${myconf} --enable-perlconnect"
- # rphillips, fixes bug #3876
- # this is fixed for me with apache2, but keeping it in here
- # for apache1 users and/or until some clever detection
- # is added <obz@gentoo.org>
- append-ldflags -lstdc++ -shared-libgcc
-
econf ${myconf} || die "Configure failed"
emake || die "Make failed"
}
@@ -48,7 +45,5 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "Install failed"
- use doc || rm -rf "${D}/usr/share/doc/${PF}/html"
-
dodoc README README_JS RELEASE src/TODO
}