summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2007-03-14 02:16:28 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2007-03-14 02:16:28 +0000
commit9631c5f7b3e918d83bd0fbfaff78ff9060427b03 (patch)
treea0790d26f7f25a67ddf3ab6bf0d398f76f43b854 /app-text/sablotron
parentRemoving older unused versions. (diff)
downloadgentoo-2-9631c5f7b3e918d83bd0fbfaff78ff9060427b03.tar.gz
gentoo-2-9631c5f7b3e918d83bd0fbfaff78ff9060427b03.tar.bz2
gentoo-2-9631c5f7b3e918d83bd0fbfaff78ff9060427b03.zip
Version bump: 1.0.3 (bug #158131)
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/ChangeLog10
-rw-r--r--app-text/sablotron/files/digest-sablotron-1.0.33
-rw-r--r--app-text/sablotron/sablotron-1.0.3.ebuild53
3 files changed, 65 insertions, 1 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 724584caaf0a..3a3c22d1add4 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/sablotron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.53 2007/03/12 23:19:03 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.54 2007/03/14 02:16:28 leonardop Exp $
+
+*sablotron-1.0.3 (14 Mar 2007)
+
+ 14 Mar 2007; Leonardo Boshell <leonardop@gentoo.org>
+ +sablotron-1.0.3.ebuild:
+ Version bump (bug #158131). Updated HOMEPAGE. Replaced einstall with "make
+ install". Fixed the 'doc' flag implementation so no files are installed
+ under /no when USE=-doc.
12 Mar 2007; Leonardo Boshell <leonardop@gentoo.org> metadata.xml:
Replacing text-markup herd with the new sgml herd.
diff --git a/app-text/sablotron/files/digest-sablotron-1.0.3 b/app-text/sablotron/files/digest-sablotron-1.0.3
new file mode 100644
index 000000000000..62f2c4d0c67b
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-1.0.3
@@ -0,0 +1,3 @@
+MD5 72654c4b832e7562f8240ea675577f5e Sablot-1.0.3.tar.gz 607597
+RMD160 bbf2b57d95efbe1fce0ba42813560df4dbde9e3a Sablot-1.0.3.tar.gz 607597
+SHA256 a0c737ada78d0d305a2a964595167e0c6d17ff0afd3b801714768deb681bf362 Sablot-1.0.3.tar.gz 607597
diff --git a/app-text/sablotron/sablotron-1.0.3.ebuild b/app-text/sablotron/sablotron-1.0.3.ebuild
new file mode 100644
index 000000000000..3d912c116b41
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.3.ebuild,v 1.1 2007/03/14 02:16:28 leonardop Exp $
+
+inherit libtool flag-o-matic
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="http://www.gingerall.org/sablotron.html"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc perl"
+
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-perl/XML-Parser-2.3 )"
+
+
+src_compile() {
+ # Don't use --without-html-dir, since that ends up installing files under
+ # the /no directory
+ local myconf="--with-html-dir=/usr/share/doc/${PF}/html"
+
+ # Please do not remove, else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/libsablot.la ...
+ elibtoolize
+
+ use perl && myconf="${myconf} --enable-perlconnect"
+
+ # rphillips, fixes bug #3876
+ # this is fixed for me with apache2, but keeping it in here
+ # for apache1 users and/or until some clever detection
+ # is added <obz@gentoo.org>
+ append-ldflags -lstdc++ -shared-libgcc
+
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+
+ use doc || rm -rf "${D}/usr/share/doc/${PF}/html"
+
+ dodoc README README_JS RELEASE src/TODO
+}