summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-23 02:01:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-23 02:01:05 +0000
commitc8b69083abcfd146e2ffd9d3cb0415f89e9e2d0a (patch)
treec2c18cb8e7f0d4eb60ba3d9f3e0a4ef7e6775212 /app-text/teckit
parentversion bump (diff)
downloadgentoo-2-c8b69083abcfd146e2ffd9d3cb0415f89e9e2d0a.tar.gz
gentoo-2-c8b69083abcfd146e2ffd9d3cb0415f89e9e2d0a.tar.bz2
gentoo-2-c8b69083abcfd146e2ffd9d3cb0415f89e9e2d0a.zip
Do not mix CFLAGS and CXXFLAGS, bug #338110
(Portage version: 2.2_rc99/cvs/Linux x86_64)
Diffstat (limited to 'app-text/teckit')
-rw-r--r--app-text/teckit/ChangeLog6
-rw-r--r--app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch16
-rw-r--r--app-text/teckit/teckit-2.5.1.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/app-text/teckit/ChangeLog b/app-text/teckit/ChangeLog
index 6f983062911b..5df0dfe6ebc3 100644
--- a/app-text/teckit/ChangeLog
+++ b/app-text/teckit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/teckit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/ChangeLog,v 1.14 2010/10/02 12:53:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/ChangeLog,v 1.15 2010/10/23 02:01:05 aballier Exp $
+
+ 23 Oct 2010; Alexis Ballier <aballier@gentoo.org> teckit-2.5.1.ebuild,
+ +files/teckit-2.5.1-mixcflagscxxflags.patch:
+ Do not mix CFLAGS and CXXFLAGS, bug #338110
02 Oct 2010; Fabian Groffen <grobian@gentoo.org> teckit-2.5.1.ebuild:
Marked ~x64-macos, bug #333981
diff --git a/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
new file mode 100644
index 000000000000..5a290f45133b
--- /dev/null
+++ b/app-text/teckit/files/teckit-2.5.1-mixcflagscxxflags.patch
@@ -0,0 +1,16 @@
+No need to pass CFLAGS twice, esp. if they are used to feed g++
+Bug #338110
+
+Index: TECkit_2_5_1/configure.ac
+===================================================================
+--- TECkit_2_5_1.orig/configure.ac
++++ TECkit_2_5_1/configure.ac
+@@ -76,7 +76,7 @@ noexpat_CFLAGS="$CFLAGS"
+ noexpat_LIBS="$LIBS"
+ AC_CHECK_LIB(expat, XML_ExpatVersion)
+ AM_CONDITIONAL(SYSTEM_EXPAT, test x$ac_cv_lib_expat_XML_ExpatVersion = xyes)
+-expat_CFLAGS="$CFLAGS"
++expat_CFLAGS=""
+ expat_LIBS="$LIBS"
+ CFLAGS="$noexpat_CFLAGS"
+ LIBS="$noexpat_LIBS"
diff --git a/app-text/teckit/teckit-2.5.1.ebuild b/app-text/teckit/teckit-2.5.1.ebuild
index 13e6328ee6a1..08158c6c8dff 100644
--- a/app-text/teckit/teckit-2.5.1.ebuild
+++ b/app-text/teckit/teckit-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/teckit-2.5.1.ebuild,v 1.14 2010/10/02 12:53:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/teckit/teckit-2.5.1.ebuild,v 1.15 2010/10/23 02:01:05 aballier Exp $
EAPI="2"
@@ -25,6 +25,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}/${P}-rc.patch"
epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-mixcflagscxxflags.patch"
rm -f configure
eautoreconf
}