summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-17 14:34:32 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-17 14:34:32 +0000
commit6a1d23571222adb36d1c58b2fee9a31b0262f49a (patch)
tree0d11af26988bad2e95deb59a99dc57adbace1392 /app-text/tofrodos
parentalpha/arm/ia64/m68k/s390/sh stable wrt #278039 (diff)
downloadgentoo-2-6a1d23571222adb36d1c58b2fee9a31b0262f49a.tar.gz
gentoo-2-6a1d23571222adb36d1c58b2fee9a31b0262f49a.tar.bz2
gentoo-2-6a1d23571222adb36d1c58b2fee9a31b0262f49a.zip
Respecting CFLAGS and LDFLAGS. Closes bug 262213
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-text/tofrodos')
-rw-r--r--app-text/tofrodos/ChangeLog6
-rw-r--r--app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch17
-rw-r--r--app-text/tofrodos/tofrodos-1.7.8.ebuild16
3 files changed, 34 insertions, 5 deletions
diff --git a/app-text/tofrodos/ChangeLog b/app-text/tofrodos/ChangeLog
index 027c76704f0b..d715c33c9016 100644
--- a/app-text/tofrodos/ChangeLog
+++ b/app-text/tofrodos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/tofrodos
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tofrodos/ChangeLog,v 1.1 2009/03/07 15:46:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tofrodos/ChangeLog,v 1.2 2009/07/17 14:34:31 vostorga Exp $
+
+ 17 Jul 2009; Víctor Ostorga <vostorga@gentoo.org>
+ +files/tofrodos-1.7.8-CFLAGS.patch, tofrodos-1.7.8.ebuild:
+ Respecting CFLAGS and LDFLAGS. Closes bug 262213
*tofrodos-1.7.8 (07 Mar 2009)
diff --git a/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch b/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch
new file mode 100644
index 000000000000..5aa0e8358565
--- /dev/null
+++ b/app-text/tofrodos/files/tofrodos-1.7.8-CFLAGS.patch
@@ -0,0 +1,17 @@
+--- Makefile.original 2009-04-11 22:46:08.000000000 -0600
++++ Makefile 2009-04-12 14:30:55.000000000 -0600
+@@ -92,14 +92,10 @@
+ OBJS = emsg.o \
+ init.o \
+ tofrodos.o \
+ utility.o
+
+-# implicit rules
+-.c.o:
+- $(CC) $(CFLAGS) $<
+-
+ # user visible rules
+ all: $(FROMDOS) $(TODOS)
+
+ clean:
+ $(RM) $(OBJS)
diff --git a/app-text/tofrodos/tofrodos-1.7.8.ebuild b/app-text/tofrodos/tofrodos-1.7.8.ebuild
index a28f89bbfb48..1204b178993d 100644
--- a/app-text/tofrodos/tofrodos-1.7.8.ebuild
+++ b/app-text/tofrodos/tofrodos-1.7.8.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/tofrodos/tofrodos-1.7.8.ebuild,v 1.1 2009/03/07 15:46:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/tofrodos/tofrodos-1.7.8.ebuild,v 1.2 2009/07/17 14:34:31 vostorga Exp $
+
+inherit eutils
DESCRIPTION="text file conversion utility that converts ASCII files between the
MSDOS format and the Unix format"
@@ -17,12 +19,18 @@ RDEPEND=""
S="${WORKDIR}/${PN}/src"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-CFLAGS.patch
+}
+
src_compile() {
- emake DEBUG=1 || die "Compile failed."
+ emake DEBUG=1 CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "Compile failed."
}
src_install() {
dobin fromdos || die
- dosym fromdos /usr/bin/todos
- doman fromdos.1
+ dosym fromdos /usr/bin/todos || die
+ doman fromdos.1 || die
}