summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-06 22:05:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-06 22:05:09 +0000
commitd286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f (patch)
treeeb20968f2bea31b2735bf561261d7c825c4fdb30 /app-text/wdiff
parentUnbundling speex and zlib. Partially fix bug #255453 (diff)
downloadgentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.tar.gz
gentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.tar.bz2
gentoo-2-d286b5cb8a8c4a3ffc4f92668c3260dd99b3ef2f.zip
Fix for bug 301171, ignore case patch
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'app-text/wdiff')
-rw-r--r--app-text/wdiff/ChangeLog10
-rw-r--r--app-text/wdiff/files/wdiff-0.5-ignore-case.patch11
-rw-r--r--app-text/wdiff/wdiff-0.5-r3.ebuild46
3 files changed, 65 insertions, 2 deletions
diff --git a/app-text/wdiff/ChangeLog b/app-text/wdiff/ChangeLog
index a4e9540b00d8..2a7e77b7718f 100644
--- a/app-text/wdiff/ChangeLog
+++ b/app-text/wdiff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/wdiff
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.32 2009/09/09 18:42:39 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.33 2010/03/06 22:05:07 jlec Exp $
+
+*wdiff-0.5-r3 (06 Mar 2010)
+
+ 06 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +wdiff-0.5-r3.ebuild,
+ +files/wdiff-0.5-ignore-case.patch:
+ Fix for bug 301171, ignore case patch
09 Sep 2009; Mike Frysinger <vapier@gentoo.org> wdiff-0.5-r2.ebuild,
+files/wdiff-0.5-headers.patch:
diff --git a/app-text/wdiff/files/wdiff-0.5-ignore-case.patch b/app-text/wdiff/files/wdiff-0.5-ignore-case.patch
new file mode 100644
index 000000000000..25d2e07d9624
--- /dev/null
+++ b/app-text/wdiff/files/wdiff-0.5-ignore-case.patch
@@ -0,0 +1,11 @@
+--- wdiff-0.5-orig/wdiff.c
++++ wdiff-0.5/wdiff.c
+@@ -895,7 +895,7 @@
+ /* Launch the diff program. */
+
+ if (ignore_case)
+- input_file = readpipe (DIFF_PROGRAM, "-c", left_side->temp_name,
++ input_file = readpipe (DIFF_PROGRAM, "-i", left_side->temp_name,
+ right_side->temp_name, NULL);
+ else
+ input_file = readpipe (DIFF_PROGRAM, left_side->temp_name,
diff --git a/app-text/wdiff/wdiff-0.5-r3.ebuild b/app-text/wdiff/wdiff-0.5-r3.ebuild
new file mode 100644
index 000000000000..d6afdf05c938
--- /dev/null
+++ b/app-text/wdiff/wdiff-0.5-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r3.ebuild,v 1.1 2010/03/06 22:05:07 jlec Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-apps/diffutils
+ sys-apps/less"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-headers.patch
+ epatch "${FILESDIR}"/${P}-segfault-fix.diff
+ epatch "${FILESDIR}"/${P}-avoid-wraps.diff
+ epatch "${FILESDIR}"/${P}-ignore-case.patch
+ sed -i 's:-ltermcap:-lncurses:' configure
+}
+
+src_compile() {
+ # Cannot use econf here because the configure script that
+ # comes with wdiff is too old to understand the standard
+ # options.
+
+ tc-export CC
+ ./configure --prefix=/usr || die
+ echo '#define HAVE_TPUTS 1' >> config.h
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog NEWS README
+ doman wdiff.1
+}