summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-24 11:12:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-24 11:12:34 +0000
commit376af7bb909a4173977e45c08ec94312e469a002 (patch)
tree5389dc54be5914fb5112563ac9f713585ea5b80c /app-text/xindy
parentQA: fix eautoreconf call (bug #316897). (diff)
downloadgentoo-2-376af7bb909a4173977e45c08ec94312e469a002.tar.gz
gentoo-2-376af7bb909a4173977e45c08ec94312e469a002.tar.bz2
gentoo-2-376af7bb909a4173977e45c08ec94312e469a002.zip
fix build with clisp-2.48, by Semen Cirit, bug #281271
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xindy')
-rw-r--r--app-text/xindy/ChangeLog8
-rw-r--r--app-text/xindy/files/xindy-2.3-clisp-2.48.patch24
-rw-r--r--app-text/xindy/xindy-2.3.ebuild12
3 files changed, 40 insertions, 4 deletions
diff --git a/app-text/xindy/ChangeLog b/app-text/xindy/ChangeLog
index fdde00b258ef..f286f9ade225 100644
--- a/app-text/xindy/ChangeLog
+++ b/app-text/xindy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/xindy
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/ChangeLog,v 1.9 2009/05/30 08:35:31 ulm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/ChangeLog,v 1.10 2010/04/24 11:12:33 aballier Exp $
+
+ 24 Apr 2010; Alexis Ballier <aballier@gentoo.org> xindy-2.3.ebuild,
+ +files/xindy-2.3-clisp-2.48.patch:
+ fix build with clisp-2.48, by Semen Cirit, bug #281271
30 May 2009; Ulrich Mueller <ulm@gentoo.org> xindy-2.3.ebuild:
Remove app-text/tetex from dependencies, bug 227443.
diff --git a/app-text/xindy/files/xindy-2.3-clisp-2.48.patch b/app-text/xindy/files/xindy-2.3-clisp-2.48.patch
new file mode 100644
index 000000000000..cb00a03f1f49
--- /dev/null
+++ b/app-text/xindy/files/xindy-2.3-clisp-2.48.patch
@@ -0,0 +1,24 @@
+diff -Nuar rte.orig/Makefile.am rte/Makefile.am
+--- rte.orig/Makefile.am 2009-09-07 11:32:27.960203413 +0300
++++ rte/Makefile.am 2009-09-07 11:33:18.297274183 +0300
+@@ -75,7 +75,7 @@
+ xindy-build-dir: $(CLISP_PREREQ)
+ $(RM_R) xindy-build-dir
+ $(MAKE) -C ordrules ordrulei.c
+- $(clisp_link) add-module-set ordrules $(fulldir) $@
++ $(clisp_link) add $(fulldir) $@ ordrules
+ cp $@/lisp.run $(binariesdir)/xindy.run
+ cp $@/lispinit.mem $(binariesdir)/base.mem
+
+diff -Nuar rte.orig/Makefile.in rte/Makefile.in
+--- rte.orig/Makefile.in 2009-09-07 11:32:28.150197349 +0300
++++ rte/Makefile.in 2009-09-07 11:32:54.205447337 +0300
+@@ -318,7 +318,7 @@
+ xindy-build-dir: $(CLISP_PREREQ)
+ $(RM_R) xindy-build-dir
+ $(MAKE) -C ordrules ordrulei.c
+- $(clisp_link) add-module-set ordrules $(fulldir) $@
++ $(clisp_link) add $(fulldir) $@ ordrules
+ cp $@/lisp.run $(binariesdir)/xindy.run
+ cp $@/lispinit.mem $(binariesdir)/base.mem
+
diff --git a/app-text/xindy/xindy-2.3.ebuild b/app-text/xindy/xindy-2.3.ebuild
index b247d90a4f44..fda70a04fbcf 100644
--- a/app-text/xindy/xindy-2.3.ebuild
+++ b/app-text/xindy/xindy-2.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/xindy-2.3.ebuild,v 1.9 2009/05/30 08:35:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xindy/xindy-2.3.ebuild,v 1.10 2010/04/24 11:12:33 aballier Exp $
+
+inherit eutils
DESCRIPTION="A Flexible Indexing System"
@@ -18,6 +20,12 @@ RDEPEND="virtual/latex-base
DEPEND="${RDEPEND}
sys-devel/flex"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ has_version '>=dev-lisp/clisp-2.48' && epatch "${FILESDIR}/${P}-clisp-2.48.patch"
+}
+
src_compile() {
local clisp_dir
clisp_dir=`clisp --version | grep "Installation directory:" | sed 's/Installation directory: //'`