summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2003-04-17 21:00:32 +0000
committerChris Houser <chouser@gentoo.org>2003-04-17 21:00:32 +0000
commit65ce8e9a718971bcd9cf22a7487594a12515988a (patch)
treec76950f99de352713130a21df477c7c3635c86fc /app-text/xlhtml/xlhtml-0.5.ebuild
parentfix (diff)
downloadgentoo-2-65ce8e9a718971bcd9cf22a7487594a12515988a.tar.gz
gentoo-2-65ce8e9a718971bcd9cf22a7487594a12515988a.tar.bz2
gentoo-2-65ce8e9a718971bcd9cf22a7487594a12515988a.zip
Initial ebuild -- alpha only
Diffstat (limited to 'app-text/xlhtml/xlhtml-0.5.ebuild')
-rw-r--r--app-text/xlhtml/xlhtml-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/xlhtml/xlhtml-0.5.ebuild b/app-text/xlhtml/xlhtml-0.5.ebuild
new file mode 100644
index 000000000000..65cd1582415d
--- /dev/null
+++ b/app-text/xlhtml/xlhtml-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xlhtml/xlhtml-0.5.ebuild,v 1.1 2003/04/17 21:00:32 chouser Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="Convert MS Excel and Powerpoint files to HTML"
+HOMEPAGE="http://chicago.sourceforge.net/xlhtml/"
+SRC_URI="mirror://sourceforge/chicago/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ # This is needed specifically for depcomp, which is necessary for
+ # building xlhtml, but isn't included.
+ touch depcomp || die "Failed to create depcomp"
+ gnuconfig_update config.sub config.guess depcomp
+
+ econf || die "econf failed for ${P}"
+ emake || die "emake failed for ${P}"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed for ${P}"
+ dodoc AUTHORS
+}