summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-09-29 17:40:24 +0000
committerHanno Böck <hanno@gentoo.org>2009-09-29 17:40:24 +0000
commit12a1d33824ae4fa357cda3d3b7e0aaf6b7c9a5ef (patch)
tree946bffc925c4340253668ecf15411fbd66b382f4 /app-text
parentStable on alpha, bug #156570 (diff)
downloadgentoo-2-12a1d33824ae4fa357cda3d3b7e0aaf6b7c9a5ef.tar.gz
gentoo-2-12a1d33824ae4fa357cda3d3b7e0aaf6b7c9a5ef.tar.bz2
gentoo-2-12a1d33824ae4fa357cda3d3b7e0aaf6b7c9a5ef.zip
wv2: gcc44 fix
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wv2/ChangeLog6
-rw-r--r--app-text/wv2/files/wv2-0.4.0-elif.patch26
-rw-r--r--app-text/wv2/wv2-0.4.0.ebuild3
3 files changed, 33 insertions, 2 deletions
diff --git a/app-text/wv2/ChangeLog b/app-text/wv2/ChangeLog
index 91f456795607..771aa38a796b 100644
--- a/app-text/wv2/ChangeLog
+++ b/app-text/wv2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/wv2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv2/ChangeLog,v 1.55 2009/09/29 09:33:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv2/ChangeLog,v 1.56 2009/09/29 17:40:23 hanno Exp $
+
+ 29 Sep 2009; Hanno Boeck <hanno@gentoo.org> wv2-0.4.0.ebuild,
+ +files/wv2-0.4.0-elif.patch:
+ Fix for gcc 4.4.
*wv2-0.4.0 (29 Sep 2009)
diff --git a/app-text/wv2/files/wv2-0.4.0-elif.patch b/app-text/wv2/files/wv2-0.4.0-elif.patch
new file mode 100644
index 000000000000..d4f352f6d739
--- /dev/null
+++ b/app-text/wv2/files/wv2-0.4.0-elif.patch
@@ -0,0 +1,26 @@
+--- src/ustring.cpp.old 2009-09-23 01:05:50.750887617 +0400
++++ src/ustring.cpp 2009-09-23 01:08:17.317619492 +0400
+@@ -78,9 +78,9 @@
+ {
+ #if defined(HAVE_FUNC_ISINF)
+ return (isinf(d) == 1);
+-#elif HAVE_FUNC_FINITE
++#elif defined(HAVE_FUNC_FINITE)
+ return finite(d) == 0 && d == d; // ### can we distinguish between + and - ?
+-#elif HAVE_FUNC__FINITE
++#elif defined(HAVE_FUNC__FINITE)
+ return _finite(d) == 0 && d == d; // ###
+ #else
+ return false;
+@@ -91,9 +91,9 @@
+ {
+ #if defined(HAVE_FUNC_ISINF)
+ return (isinf(d) == -1);
+-#elif HAVE_FUNC_FINITE
++#elif defined(HAVE_FUNC_FINITE)
+ return finite(d) == 0 && d == d; // ###
+-#elif HAVE_FUNC__FINITE
++#elif defined(HAVE_FUNC__FINITE)
+ return _finite(d) == 0 && d == d; // ###
+ #else
+ return false;
diff --git a/app-text/wv2/wv2-0.4.0.ebuild b/app-text/wv2/wv2-0.4.0.ebuild
index 4035e2348723..1c78a5e91346 100644
--- a/app-text/wv2/wv2-0.4.0.ebuild
+++ b/app-text/wv2/wv2-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv2/wv2-0.4.0.ebuild,v 1.1 2009/09/29 09:33:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv2/wv2-0.4.0.ebuild,v 1.2 2009/09/29 17:40:23 hanno Exp $
EAPI=1
@@ -26,6 +26,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PV}-cmake.patch
+ "${FILESDIR}"/${P}-elif.patch
)
src_configure() {