summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-06 02:45:05 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-06 02:45:05 +0000
commit352cc704be6377c46fc5c59e4a039aaea0afe8c3 (patch)
tree4a395d1384f906a3bc857129278bbeb3739e8038 /app-text
parentkeyword ~arm, bug #437250 (diff)
downloadgentoo-2-352cc704be6377c46fc5c59e4a039aaea0afe8c3.tar.gz
gentoo-2-352cc704be6377c46fc5c59e4a039aaea0afe8c3.tar.bz2
gentoo-2-352cc704be6377c46fc5c59e4a039aaea0afe8c3.zip
Version bump. Fix build with >=boost-1.50.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/ChangeLog7
-rw-r--r--app-text/highlight/highlight-3.12.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index 5bc24e1f83f3..861a8fd5819d 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/highlight
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.53 2012/09/17 14:59:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.54 2012/10/06 02:45:05 radhermit Exp $
+
+*highlight-3.12 (06 Oct 2012)
+
+ 06 Oct 2012; Tim Harder <radhermit@gentoo.org> +highlight-3.12.ebuild:
+ Version bump. Fix build with >=boost-1.50.
17 Sep 2012; Alexis Ballier <aballier@gentoo.org> highlight-3.9.ebuild:
keyword ~amd64-fbsd
diff --git a/app-text/highlight/highlight-3.12.ebuild b/app-text/highlight/highlight-3.12.ebuild
new file mode 100644
index 000000000000..7fc8e8394669
--- /dev/null
+++ b/app-text/highlight/highlight-3.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.12.ebuild,v 1.1 2012/10/06 02:45:05 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs qt4-r2 flag-o-matic boost-utils
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de/"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="examples qt4"
+
+RDEPEND="dev-lang/lua
+ qt4? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+
+pkg_setup() {
+ myhlopts=(
+ "CXX=$(tc-getCXX)"
+ "AR=$(tc-getAR)"
+ "LDFLAGS=${LDFLAGS}"
+ "CFLAGS=${CXXFLAGS} -I$(boost-utils_get_includedir)"
+ "DESTDIR=${D}"
+ "PREFIX=${EPREFIX}/usr"
+ "LUA_CFLAGS="
+ "HL_CONFIG_DIR=${EPREFIX}/etc/highlight/"
+ "HL_DATA_DIR=${EPREFIX}/usr/share/highlight/"
+ "doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
+ "conf_dir=${EPREFIX}/etc/highlight/"
+ )
+}
+
+src_prepare() {
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+
+ append-cxxflags -I$(boost-utils_get_includedir)
+}
+
+src_compile() {
+ emake -f makefile "${myhlopts[@]}"
+ if use qt4 ; then
+ cd src/gui-qt
+ eqmake4 'DEFINES+=DATA_DIR=\\\"'"${EPREFIX}"'/usr/share/${PN}/\\\" CONFIG_DIR=\\\"'"${EPREFIX}"'/etc/${PN}/\\\" DOC_DIR=\\\"'"${EPREFIX}"'/usr/share/doc/${PF}/\\\"'
+ emake
+ fi
+}
+
+src_install() {
+ emake -f makefile "${myhlopts[@]}" install
+ use qt4 && emake -f makefile "${myhlopts[@]}" install-gui
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ else
+ rm -rf "${ED}"/usr/share/doc/${PF}/examples
+ fi
+}