summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-01-14 00:51:29 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-01-14 00:51:29 +0000
commit4f33e5915a42ee3e44d2fe2f11233f7489421581 (patch)
treee775317a6bc6b35ef82ce9b096cfea04a29981c4 /app-text
parentadd USE flag emacs for dependency on corresponding GNU Emacs mode, see bug 20... (diff)
downloadgentoo-2-4f33e5915a42ee3e44d2fe2f11233f7489421581.tar.gz
gentoo-2-4f33e5915a42ee3e44d2fe2f11233f7489421581.tar.bz2
gentoo-2-4f33e5915a42ee3e44d2fe2f11233f7489421581.zip
add proper GNU Emacs support, fixes bug 194734
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/namazu/ChangeLog10
-rw-r--r--app-text/namazu/files/50namazu-gentoo.el5
-rw-r--r--app-text/namazu/files/digest-namazu-2.0.17-r13
-rw-r--r--app-text/namazu/namazu-2.0.17-r1.ebuild89
4 files changed, 105 insertions, 2 deletions
diff --git a/app-text/namazu/ChangeLog b/app-text/namazu/ChangeLog
index d87cefc041a2..634d3a828543 100644
--- a/app-text/namazu/ChangeLog
+++ b/app-text/namazu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/namazu
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.22 2007/10/03 08:21:03 tgall Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/ChangeLog,v 1.23 2008/01/14 00:51:28 opfer Exp $
+
+*namazu-2.0.17-r1 (14 Jan 2008)
+
+ 14 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
+ +files/50namazu-gentoo.el, +namazu-2.0.17-r1.ebuild:
+ add proper GNU Emacs support, fixes bug 194734
03 Oct 2007; Tom Gall <tgall@gentoo.org> namazu-2.0.17.ebuild:
stable on ppc64
diff --git a/app-text/namazu/files/50namazu-gentoo.el b/app-text/namazu/files/50namazu-gentoo.el
new file mode 100644
index 000000000000..56bbce50af82
--- /dev/null
+++ b/app-text/namazu/files/50namazu-gentoo.el
@@ -0,0 +1,5 @@
+
+;; namazu site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'namazu "namazu" nil t)
diff --git a/app-text/namazu/files/digest-namazu-2.0.17-r1 b/app-text/namazu/files/digest-namazu-2.0.17-r1
new file mode 100644
index 000000000000..5bd37c0646a6
--- /dev/null
+++ b/app-text/namazu/files/digest-namazu-2.0.17-r1
@@ -0,0 +1,3 @@
+MD5 83a62ae5f8a915dcc2745de1950e4a96 namazu-2.0.17.tar.gz 1379981
+RMD160 f6b85aae280fa6dca38dcf6c4c3427b683610994 namazu-2.0.17.tar.gz 1379981
+SHA256 4697c019e7d19f6bf1aaeb9731fc3b4580877dbff4099b120e7002d13574e745 namazu-2.0.17.tar.gz 1379981
diff --git a/app-text/namazu/namazu-2.0.17-r1.ebuild b/app-text/namazu/namazu-2.0.17-r1.ebuild
new file mode 100644
index 000000000000..442a9beaf2bb
--- /dev/null
+++ b/app-text/namazu/namazu-2.0.17-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/namazu/namazu-2.0.17-r1.ebuild,v 1.1 2008/01/14 00:51:28 opfer Exp $
+
+inherit elisp-common
+
+IUSE="chasen cjk emacs kakasi nls tk"
+
+DESCRIPTION="Namazu is a full-text search engine"
+HOMEPAGE="http://www.namazu.org/"
+SRC_URI="http://www.namazu.org/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+
+DEPEND=">=dev-perl/File-MMagic-1.20
+ chasen? ( app-text/chasen )
+ cjk? ( app-i18n/nkf )
+ emacs? ( virtual/emacs )
+ kakasi? ( dev-perl/Text-Kakasi )
+ nls? ( sys-devel/gettext )
+ tk? (
+ dev-lang/tk
+ www-client/lynx
+ )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "s:\(rm -f \$(filterdir).*$\):# \1:" filter/Makefile.in
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use tk && myconf="--with-namazu=/usr/bin/namazu
+ --with-mknmz=/usr/bin/mknmz
+ --with-indexdir=/var/lib/namazu/index"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable tk tknamazu) \
+ ${myconf} \
+ || die
+ emake || die
+
+ if use emacs; then
+ cd lisp
+ elisp-comp {namazu,gnus-nmz-1}.el || die "elisp-comp failed"
+ fi
+}
+
+src_install () {
+
+ emake DESTDIR="${D}" install || die
+
+ rm -rf "${D}"/usr/share/namazu/{doc,etc}
+
+ dodoc AUTHORS CREDITS ChangeLog* HACKING* NEWS README* THANKS TODO
+ dohtml -r doc/*
+
+ insinto /usr/share/doc/${P}
+ doins etc/*.png
+
+ if use emacs; then
+ elisp-install ${PN} lisp/{namazu,gnus-nmz-1}.el{,c} \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+
+ docinto lisp
+ dodoc lisp/ChangeLog*
+ fi
+
+}
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}