summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-11-02 05:20:01 +0000
committerAron Griffis <agriffis@gentoo.org>2003-11-02 05:20:01 +0000
commit5607f87527a071b642e043536e83f77fea307a00 (patch)
tree0b434d3b09142ca93207a424b58de1c2716c48a5 /app-text
parentupdate for new api (diff)
downloadgentoo-2-5607f87527a071b642e043536e83f77fea307a00.tar.gz
gentoo-2-5607f87527a071b642e043536e83f77fea307a00.tar.bz2
gentoo-2-5607f87527a071b642e043536e83f77fea307a00.zip
add ~alpha
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/ChangeLog6
-rw-r--r--app-text/enchant/Manifest7
-rw-r--r--app-text/enchant/enchant-1.0.0.ebuild10
-rw-r--r--app-text/enchant/files/enchant-1.0.0-alpha.patch29
4 files changed, 46 insertions, 6 deletions
diff --git a/app-text/enchant/ChangeLog b/app-text/enchant/ChangeLog
index d0d30eb707e7..fdbde41fb8fb 100644
--- a/app-text/enchant/ChangeLog
+++ b/app-text/enchant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/enchant
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.8 2003/10/26 19:52:00 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/ChangeLog,v 1.9 2003/11/02 05:19:57 agriffis Exp $
+
+ 02 Nov 2003; Aron Griffis <agriffis@gentoo.org> enchant-1.0.0.ebuild,
+ files/enchant-1.0.0-alpha.patch:
+ Add patch for 64-bit compilation and add ~alpha to KEYWORDS
*enchant-1.1.1 (26 Oct 2003)
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 11e0fed60627..672c96939f6f 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,6 +1,7 @@
-MD5 9442ab7b04ed8076183baf8b8f787cb9 enchant-1.1.1.ebuild 761
-MD5 7cd6e3b56b8e137eebe08144e23b6b20 enchant-1.0.0.ebuild 756
-MD5 c8773a689938579abea207f5181ad564 ChangeLog 1322
+MD5 f9261b95729c51cf58f43d0077ea2d6d ChangeLog 1495
+MD5 0671ff8a41c55b784d754877c7795dfd enchant-1.0.0.ebuild 875
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 9442ab7b04ed8076183baf8b8f787cb9 enchant-1.1.1.ebuild 761
MD5 9eea1c1607ac139d4fe5716900da9570 files/digest-enchant-1.0.0 65
MD5 d6368d91049f7483ff7868c99d86b3be files/digest-enchant-1.1.1 65
+MD5 cdba960f66d079da7010a9f923d08c3b files/enchant-1.0.0-alpha.patch 1233
diff --git a/app-text/enchant/enchant-1.0.0.ebuild b/app-text/enchant/enchant-1.0.0.ebuild
index 5414b3a65363..0f5309bdb787 100644
--- a/app-text/enchant/enchant-1.0.0.ebuild
+++ b/app-text/enchant/enchant-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.0.0.ebuild,v 1.2 2003/09/28 13:05:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.0.0.ebuild,v 1.3 2003/11/02 05:19:57 agriffis Exp $
inherit gnome2
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/abiword/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
IUSE=""
@@ -25,3 +25,9 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
DOCS="AUTHORS BUGS COPYING.LIB ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/enchant-1.0.0-alpha.patch || die "epatch failed"
+}
diff --git a/app-text/enchant/files/enchant-1.0.0-alpha.patch b/app-text/enchant/files/enchant-1.0.0-alpha.patch
new file mode 100644
index 000000000000..2ea15e1b6c01
--- /dev/null
+++ b/app-text/enchant/files/enchant-1.0.0-alpha.patch
@@ -0,0 +1,29 @@
+--- enchant-1.0.0/src/ispell/lookup.cpp.aron 2003-08-26 09:20:40.000000000 -0400
++++ enchant-1.0.0/src/ispell/lookup.cpp 2003-11-02 00:08:56.000000000 -0500
+@@ -381,22 +381,22 @@
+ if (dp->word == (char *) -1)
+ dp->word = NULL;
+ else
+- dp->word = &m_hashstrings [ reinterpret_cast<int>(dp->word) ];
++ dp->word = &m_hashstrings [ reinterpret_cast<unsigned long>(dp->word) ];
+ if (dp->next == (struct dent *) -1)
+ dp->next = NULL;
+ else
+- dp->next = &m_hashtbl [ reinterpret_cast<int>(dp->next) ];
++ dp->next = &m_hashtbl [ reinterpret_cast<unsigned long>(dp->next) ];
+ }
+ }
+
+ for (i = m_numsflags + m_numpflags, entry = m_sflaglist; --i >= 0; entry++)
+ {
+ if (entry->stripl)
+- entry->strip = reinterpret_cast<ichar_t *>(&m_hashstrings[reinterpret_cast<int>(entry->strip)]);
++ entry->strip = reinterpret_cast<ichar_t *>(&m_hashstrings[reinterpret_cast<unsigned long>(entry->strip)]);
+ else
+ entry->strip = NULL;
+ if (entry->affl)
+- entry->affix = reinterpret_cast<ichar_t *>(&m_hashstrings[reinterpret_cast<int>(entry->affix)]);
++ entry->affix = reinterpret_cast<ichar_t *>(&m_hashstrings[reinterpret_cast<unsigned long>(entry->affix)]);
+ else
+ entry->affix = NULL;
+ }