summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 20:33:06 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 20:33:06 +0000
commit571c22b34af05f2cb47566d1978dd823b62cd54a (patch)
tree61ccb9bd3246e8b421e3846a9ebee51443ff2a5c /app-text
parentRestrict libodfgen dependency. (diff)
downloadgentoo-2-571c22b34af05f2cb47566d1978dd823b62cd54a.tar.gz
gentoo-2-571c22b34af05f2cb47566d1978dd823b62cd54a.tar.bz2
gentoo-2-571c22b34af05f2cb47566d1978dd823b62cd54a.zip
Version bump. Thanks to Andreas Sturmlechner.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libodfgen/ChangeLog8
-rw-r--r--app-text/libodfgen/libodfgen-0.1.1.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-text/libodfgen/ChangeLog b/app-text/libodfgen/ChangeLog
index 0e7d4ed7e100..6ca0fa354517 100644
--- a/app-text/libodfgen/ChangeLog
+++ b/app-text/libodfgen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/libodfgen
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.12 2014/09/13 20:16:25 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.13 2014/09/13 20:33:06 dilfridge Exp $
+
+*libodfgen-0.1.1 (13 Sep 2014)
+
+ 13 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libodfgen-0.1.1.ebuild:
+ Version bump. Thanks to Andreas Sturmlechner.
13 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org>
-libodfgen-0.0.2.ebuild:
diff --git a/app-text/libodfgen/libodfgen-0.1.1.ebuild b/app-text/libodfgen/libodfgen-0.1.1.ebuild
new file mode 100644
index 000000000000..ca4ec004e2e5
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/libodfgen-0.1.1.ebuild,v 1.1 2014/09/13 20:33:06 dilfridge Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+# git://git.code.sf.net/p/libwpd/libodfgen
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}