summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-08 22:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-08 22:56:33 +0000
commit596b576430fcc73a6b68bbedb8231673f47cf255 (patch)
treeb13907cbb0b1011208572a96a33b604a1c1feb3c /app-text
parentsmall fix to conf.d entry (Manifest recommit) (diff)
downloadgentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.tar.gz
gentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.tar.bz2
gentoo-2-596b576430fcc73a6b68bbedb8231673f47cf255.zip
add inherit eutils
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmltidy/htmltidy-2.7.18-r2.ebuild18
-rw-r--r--app-text/htmltidy/htmltidy-3.10.29.ebuild20
-rw-r--r--app-text/kbarcode/kbarcode-1.7.2.ebuild9
-rw-r--r--app-text/lout/lout-3.25-r1.ebuild6
-rw-r--r--app-text/openjade/openjade-1.3.2-r1.ebuild17
-rw-r--r--app-text/pep/pep-2.8.ebuild10
-rw-r--r--app-text/ptex/ptex-3.1.3.ebuild11
-rw-r--r--app-text/rman/rman-3.1.ebuild15
8 files changed, 48 insertions, 58 deletions
diff --git a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
index e375099132c8..2f5f61ffd4a6 100644
--- a/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
+++ b/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.1 2003/12/20 05:23:52 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-2.7.18-r2.ebuild,v 1.2 2004/04/08 22:53:10 vapier Exp $
+
+inherit eutils
# convert from normalized gentoo version number to htmltidy's wacky date thing
parts=(${PV//./ })
@@ -9,36 +11,31 @@ MY_P=tidy_src_${vers}
S=${WORKDIR}/tidy
DESCRIPTION="Tidy the layout and correct errors in HTML and XML documents"
+HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz"
-HOMEPAGE="http://tidy.sourceforge.net/"
-LICENSE="GPL-2"
-IUSE="xml doc"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="xml doc"
DEPEND=""
src_unpack() {
-
unpack ${A}
cd ${S}
use xml && epatch ${FILESDIR}/htmltidy-dbpatch.diff
# Prevent tidy from chown/grp'ing itself to 'tidy:tidy'
sed -i -e "s:chgrp\|chown:#&:" Makefile
-
}
src_compile() {
-
emake OTHERCFLAGS="${CFLAGS}" || die "emake failed"
-
}
src_install() {
-
# Need to move the man page around, thanks to the flaky Makefile
cp ${S}/htmldoc/man_page.txt ${S}/man_page.txt
@@ -51,5 +48,4 @@ src_install() {
dohtml *.html *.gif *.css
# and the api documentation if we have USE="doc"
use doc && dohtml -r api
-
}
diff --git a/app-text/htmltidy/htmltidy-3.10.29.ebuild b/app-text/htmltidy/htmltidy-3.10.29.ebuild
index de1791a83766..caaf2fae5af1 100644
--- a/app-text/htmltidy/htmltidy-3.10.29.ebuild
+++ b/app-text/htmltidy/htmltidy-3.10.29.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.7 2004/02/27 21:19:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmltidy/htmltidy-3.10.29.ebuild,v 1.8 2004/04/08 22:53:45 vapier Exp $
+
+inherit eutils
# Convert gentoo version number x.y.z to date xyz for
# tidy's source numbering by date
@@ -14,14 +16,13 @@ HOMEPAGE="http://tidy.sourceforge.net/"
SRC_URI="http://tidy.sourceforge.net/src/old/${MY_P}.tgz
http://tidy.sourceforge.net/docs/tidy_docs.tgz
xml? ( http://www.cise.ufl.edu/~ppadala/tidy/html2db.tar.gz )"
-LICENSE="GPL-2"
-IUSE="debug doc xml"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc alpha ~amd64"
+IUSE="debug doc xml"
src_unpack() {
-
unpack ${A}
cd ${S}
# Required to setup the source dist for autotools
@@ -32,7 +33,7 @@ src_unpack() {
# Stop tidy from appending -O2 to our CFLAGS
sed -i -e "/save_cflags/s/\ \-O2//" configure.in
- if [ `use xml` ]; then
+ if use xml ; then
# Apply the docbook patch to tidy sources
epatch ${FILESDIR}/03-${PN}-docbook.patch
@@ -44,26 +45,21 @@ src_unpack() {
sed -i -e "/TIDYDIR\=/s:\.\.:${S}:" \
-e "/LIBDIR\=/s:lib:src\/\.libs\/:" \
${WORKDIR}/html2db/Makefile
-
fi
-
}
src_compile() {
-
export WANT_AUTOMAKE=1.5 WANT_AUTOCONF=2.5
econf `use_enable debug` || die
emake || die
- if [ `use xml` ]; then
+ if use xml ; then
cd ${WORKDIR}/html2db
make || die
fi
-
}
src_install() {
-
make DESTDIR=${D} install || die
use xml && dobin ${WORKDIR}/html2db/html2db
@@ -79,6 +75,4 @@ src_install() {
# If use 'doc' is set, then we also want to install the
# api documentation
use doc && dohtml -r api
-
}
-
diff --git a/app-text/kbarcode/kbarcode-1.7.2.ebuild b/app-text/kbarcode/kbarcode-1.7.2.ebuild
index 32f6e529e479..aa992ba9704b 100644
--- a/app-text/kbarcode/kbarcode-1.7.2.ebuild
+++ b/app-text/kbarcode/kbarcode-1.7.2.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbarcode/kbarcode-1.7.2.ebuild,v 1.3 2004/03/07 09:50:49 centic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbarcode/kbarcode-1.7.2.ebuild,v 1.4 2004/04/08 22:54:03 vapier Exp $
-inherit kde
+inherit kde eutils
need-kde 3
-IUSE="imagemagick"
DESCRIPTION="A KDE 3.x solution for barcode handling."
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.kbarcode.net/"
+
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="imagemagick"
DEPEND=">=kde-base/kdelibs-3
>=app-text/barcode-0.98"
-
RDEPEND="${DEPEND}
imagemagick? ( media-gfx/imagemagick )"
@@ -22,4 +22,3 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-default-parameter.patch
}
-
diff --git a/app-text/lout/lout-3.25-r1.ebuild b/app-text/lout/lout-3.25-r1.ebuild
index 8ebdb9c127f4..0009da83eb0d 100644
--- a/app-text/lout/lout-3.25-r1.ebuild
+++ b/app-text/lout/lout-3.25-r1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.25-r1.ebuild,v 1.8 2004/03/12 09:18:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.25-r1.ebuild,v 1.9 2004/04/08 22:54:20 vapier Exp $
+
+inherit eutils
DESCRIPTION="high-level language for document formatting"
HOMEPAGE="http://snark.ptc.spbu.ru/~uwe/lout/"
SRC_URI="http://www.tex.ac.uk/tex-archive/support/lout/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc"
SLOT="0"
+KEYWORDS="x86 sparc"
DEPEND=">=sys-libs/zlib-1.1.4"
RDEPEND=""
diff --git a/app-text/openjade/openjade-1.3.2-r1.ebuild b/app-text/openjade/openjade-1.3.2-r1.ebuild
index 167b32396ec4..b28235c9645b 100644
--- a/app-text/openjade/openjade-1.3.2-r1.ebuild
+++ b/app-text/openjade/openjade-1.3.2-r1.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.14 2004/03/21 07:58:40 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/openjade/openjade-1.3.2-r1.ebuild,v 1.15 2004/04/08 22:55:20 vapier Exp $
-inherit libtool sgml-catalog
+inherit libtool sgml-catalog eutils
-S=${WORKDIR}/${P}
-IUSE=""
DESCRIPTION="Jade is an implemetation of DSSSL - an ISO standard for formatting SGML and XML documents"
-SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
HOMEPAGE="http://openjade.sourceforge.net"
-SLOT="0"
+SRC_URI="mirror://sourceforge/openjade/${P}.tar.gz"
+
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="ia64 x86 amd64 hppa ~ppc alpha sparc mips"
+IUSE=""
RDEPEND="app-text/sgml-common
>=app-text/opensp-1.5-r1"
-
DEPEND="dev-lang/perl
${RDEPEND}"
-KEYWORDS="ia64 x86 amd64 hppa ~ppc alpha sparc mips"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -57,7 +55,6 @@ src_compile() {
}
src_install() {
-
dodir /usr
dodir /usr/lib
make prefix=${D}/usr \
diff --git a/app-text/pep/pep-2.8.ebuild b/app-text/pep/pep-2.8.ebuild
index e7de0b69be1d..49e5da076093 100644
--- a/app-text/pep/pep-2.8.ebuild
+++ b/app-text/pep/pep-2.8.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.2 2004/03/15 15:37:06 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pep/pep-2.8.ebuild,v 1.3 2004/04/08 22:55:45 vapier Exp $
+
+inherit eutils
DESCRIPTION="Pep is a general purpose filter and file cleaning program"
HOMEPAGE="http://folk.uio.no/gisle/enjoy/pep.html"
SRC_URI="http://folk.uio.no/gisle/enjoy/${PN}${PV//./}.zip"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
+
DEPEND="app-arch/unzip
virtual/glibc"
RDEPEND="virtual/glibc"
@@ -18,7 +21,6 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
-
# pep does not come with autconf so here's a patch to configure
# Makefile with the correct path
epatch ${FILESDIR}/${P}-gentoo.patch || die "epatch failed"
@@ -31,7 +33,7 @@ src_compile() {
}
src_install() {
- dobin pep
+ dobin pep || die
doman Doc/pep.1
insinto /usr/share/pep
diff --git a/app-text/ptex/ptex-3.1.3.ebuild b/app-text/ptex/ptex-3.1.3.ebuild
index a1ad173459f0..ca7d585e6f14 100644
--- a/app-text/ptex/ptex-3.1.3.ebuild
+++ b/app-text/ptex/ptex-3.1.3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.3.ebuild,v 1.5 2004/03/14 21:02:47 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.3.ebuild,v 1.6 2004/04/08 22:56:07 vapier Exp $
PTEX_TEXMF_PV=2.1
TETEX_PV=2.0.2
-inherit tetex
+inherit tetex eutils
DESCRIPTION="The ASCII publishing TeX distribution"
HOMEPAGE="http://www.ascii.co.jp/pb/ptex/"
@@ -19,14 +19,13 @@ SRC_URI="${SRC_URI}
${SRC_PATH_PTEX}/tetex/${PTEX_TEXMF}
${SRC_PATH_PTEX}/dvips/dvipsk-jpatch-p1.6.tar.gz"
-KEYWORDS="x86 alpha amd64 ~sparc"
-SLOT="0"
LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="x86 alpha amd64 ~sparc"
PDEPEND="app-text/xdvik"
src_unpack() {
-
tetex_src_unpack
einfo "Unpacking pTeX sources..."
@@ -42,7 +41,6 @@ src_unpack() {
}
src_compile() {
-
tetex_src_compile
cat >>${S}/texk/web2c/fmtutil.cnf<<-EOF
@@ -65,7 +63,6 @@ src_compile() {
}
src_install() {
-
tetex_src_install
einfo "Installing pTeX..."
diff --git a/app-text/rman/rman-3.1.ebuild b/app-text/rman/rman-3.1.ebuild
index 8e58bead745c..e8e9c495c6cc 100644
--- a/app-text/rman/rman-3.1.ebuild
+++ b/app-text/rman/rman-3.1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.1.ebuild,v 1.3 2004/03/12 08:49:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/rman/rman-3.1.ebuild,v 1.4 2004/04/08 22:56:33 vapier Exp $
+
+inherit eutils
DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
-SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
HOMEPAGE="http://polyglotman.sourceforge.net/"
-KEYWORDS="x86 ppc sparc"
-SLOT="0"
+SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
+
LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
DEPEND=""
@@ -21,7 +24,7 @@ src_compile() {
emake CFLAGS="${CFLAGS} -finline-functions" || die "make failed"
}
-src_install () {
- dobin ${PN}
+src_install() {
+ dobin ${PN} || die
doman ${PN}.1
}