summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-18 21:05:22 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-18 21:05:22 +0000
commit6d1c1ff93009bedec6cb351b58b8e03cc4f481e2 (patch)
tree6ab00b4148c3f093022aea7a304f84dc6b83ad5e /app-text
parentuse dohtml for html file (bug 23048); simplify ebuild, use einstall (diff)
downloadgentoo-2-6d1c1ff93009bedec6cb351b58b8e03cc4f481e2.tar.gz
gentoo-2-6d1c1ff93009bedec6cb351b58b8e03cc4f481e2.tar.bz2
gentoo-2-6d1c1ff93009bedec6cb351b58b8e03cc4f481e2.zip
wrap alpha in src_compile
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gpdf/ChangeLog7
-rw-r--r--app-text/gpdf/Manifest4
-rw-r--r--app-text/gpdf/gpdf-0.102.ebuild10
3 files changed, 12 insertions, 9 deletions
diff --git a/app-text/gpdf/ChangeLog b/app-text/gpdf/ChangeLog
index 5f6108db1dac..558cb8a5262a 100644
--- a/app-text/gpdf/ChangeLog
+++ b/app-text/gpdf/ChangeLog
@@ -1,10 +1,11 @@
# ChangeLog for app-text/gpdf
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.2 2003/06/13 19:48:21 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.3 2003/06/18 21:05:13 liquidx Exp $
13 Jun 2003; Alastair Tse <liquidx@gentoo.org> gpdf-0.102.ebuild:
- fixed many b0rkages like multiple RDEPEND defined, using append-flags without
- inheriting flag-o-matic
+ fixed multiple RDEPEND defined, using append-flags without
+ inheriting flag-o-matic. also, put "use alpha" inside a function otherwise
+ it will cause sourcing errors in bash.
*gpdf-0.102 (13 Jun 2003)
diff --git a/app-text/gpdf/Manifest b/app-text/gpdf/Manifest
index 6e85c812e37c..6488b66350ff 100644
--- a/app-text/gpdf/Manifest
+++ b/app-text/gpdf/Manifest
@@ -1,3 +1,3 @@
-MD5 18d75f519270ef6db3a6b98fd6f42fe4 ChangeLog 544
-MD5 679386aa49abdc1c34295244e2b11f4a gpdf-0.102.ebuild 775
+MD5 7fd7f3ce90e2f226354c70d11d36fa31 ChangeLog 617
+MD5 1a09a7150808b63eab66d6b0b9d80ade gpdf-0.102.ebuild 736
MD5 8cc87715353a900c2b646e4129df3e27 files/digest-gpdf-0.102 63
diff --git a/app-text/gpdf/gpdf-0.102.ebuild b/app-text/gpdf/gpdf-0.102.ebuild
index 4815e7d177fb..93a51d6c012b 100644
--- a/app-text/gpdf/gpdf-0.102.ebuild
+++ b/app-text/gpdf/gpdf-0.102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-0.102.ebuild,v 1.2 2003/06/13 19:48:21 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-0.102.ebuild,v 1.3 2003/06/18 21:05:13 liquidx Exp $
inherit flag-o-matic gnome2
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog COPYING* MAINTAINERS TODO NEWS README"
-# This is required to build on alpha but it doesn't actually RUN there
-# yet.
-#use alpha && append-flags -fPIC
+src_compile() {
+ use alpha && append-flags -fPIC
+ gnome2_src_compile
+}
+