summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-10-24 06:51:47 +0000
committerMike Gardiner <obz@gentoo.org>2003-10-24 06:51:47 +0000
commit8d1cef9031266cf14d82811837cee2e406524ce8 (patch)
treea2e8d596feb5edd52c95013c164e478796939023 /app-text
parentInitial commit (diff)
downloadgentoo-2-8d1cef9031266cf14d82811837cee2e406524ce8.tar.gz
gentoo-2-8d1cef9031266cf14d82811837cee2e406524ce8.tar.bz2
gentoo-2-8d1cef9031266cf14d82811837cee2e406524ce8.zip
added head-fix.patch
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmlto/ChangeLog7
-rw-r--r--app-text/xmlto/Manifest5
-rw-r--r--app-text/xmlto/files/xmlto-0.0.15-head-fix.patch20
-rw-r--r--app-text/xmlto/xmlto-0.0.15.ebuild10
4 files changed, 38 insertions, 4 deletions
diff --git a/app-text/xmlto/ChangeLog b/app-text/xmlto/ChangeLog
index 2349bf3fea9b..7beb0902cd91 100644
--- a/app-text/xmlto/ChangeLog
+++ b/app-text/xmlto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xmlto
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.3 2003/10/24 03:53:00 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.4 2003/10/24 06:51:30 obz Exp $
+
+ 24 Oct 2003; Mike Gardiner <obz@gentoo.org> xmlto-0.0.15.ebuild,
+ files/xmlto-0.0.15-head-fix.patch:
+ Added head-fix.patch to use head -n <num> instead of the obsoleted head -<num>
+ syntax.
24 Oct 2003; Mike Gardiner <obz@gentoo.org> xmlto-0.0.15.ebuild:
Sharpened up the docbook-xsl-stylesheets dependency to 1.62.0
diff --git a/app-text/xmlto/Manifest b/app-text/xmlto/Manifest
index 633ab174ebc7..d9b96c268b7b 100644
--- a/app-text/xmlto/Manifest
+++ b/app-text/xmlto/Manifest
@@ -1,4 +1,5 @@
-MD5 99f3a5c1cb0bd5b539fdf6a6b395144e xmlto-0.0.15.ebuild 951
-MD5 631dcc32eeb3e5cdd8bb7e9ecaa53e8a ChangeLog 803
+MD5 06bdf487d8c0c383a9b4c0c78687feb9 xmlto-0.0.15.ebuild 1033
+MD5 f889539f20b959af312bef1ca30148db ChangeLog 999
MD5 c472f5fd1646eb8bca71d8df5cb2bdcc metadata.xml 164
MD5 1cfec32ebd5d3739c8040ed9cfb1f4ae files/digest-xmlto-0.0.15 64
+MD5 f93a45750c50ece36b816d374dde7e28 files/xmlto-0.0.15-head-fix.patch 620
diff --git a/app-text/xmlto/files/xmlto-0.0.15-head-fix.patch b/app-text/xmlto/files/xmlto-0.0.15-head-fix.patch
new file mode 100644
index 000000000000..b834184a6b8a
--- /dev/null
+++ b/app-text/xmlto/files/xmlto-0.0.15-head-fix.patch
@@ -0,0 +1,20 @@
+--- xmlto.in.orig 2003-10-24 14:25:44.644458792 +0800
++++ xmlto.in 2003-10-24 14:26:03.218635088 +0800
+@@ -97,7 +97,7 @@
+ if [ -x /usr/bin/locale ]
+ then
+ # For paper sizes we know about, specify them.
+- h=$(locale LC_PAPER 2>/dev/null | head -1)
++ h=$(locale LC_PAPER 2>/dev/null | head -n 1)
+ if [ "$h" = "297" ]
+ then
+ papertype=A4
+@@ -248,7 +248,7 @@
+ fi
+
+ # Decide what source format this is. Default to DocBook.
+-rootel=$(head -2 "$INPUT_FILE" | \
++rootel=$(head -n 2 "$INPUT_FILE" | \
+ sed -e 's/^<?[^?>]*?>//g' -e 's/^<![^>]*>//g' -e 's/^<\([^ ]*\).*$/\1/')
+ case $(echo $rootel) in
+ fo:root)
diff --git a/app-text/xmlto/xmlto-0.0.15.ebuild b/app-text/xmlto/xmlto-0.0.15.ebuild
index c9a258c8f81f..4149f0d10a82 100644
--- a/app-text/xmlto/xmlto-0.0.15.ebuild
+++ b/app-text/xmlto/xmlto-0.0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.15.ebuild,v 1.4 2003/10/24 03:53:00 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.15.ebuild,v 1.5 2003/10/24 06:51:30 obz Exp $
DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
HOMEPAGE="http://cyberelk.net/tim/xmlto/"
@@ -18,6 +18,14 @@ DEPEND="app-shells/bash
# Passivetex/xmltex need some sorting out, we'll include pdf/dvi/tex
# support in the first revision to xmlto <obz@gentoo.org>
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-head-fix.patch
+
+}
+
src_compile() {
econf || die