summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-12 12:27:28 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-12 12:27:28 +0000
commit90f904ba7d74de34ae93fd19997c96f898ca6b01 (patch)
treea6df46b237715d5c494fd773d4434dd8d53a6fa8 /app-text
parentWarn users if USE="oss" is disabled wrt #308919. (diff)
downloadgentoo-2-90f904ba7d74de34ae93fd19997c96f898ca6b01.tar.gz
gentoo-2-90f904ba7d74de34ae93fd19997c96f898ca6b01.tar.bz2
gentoo-2-90f904ba7d74de34ae93fd19997c96f898ca6b01.zip
Fix bug 302900
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/rarian/ChangeLog10
-rw-r--r--app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch13
-rw-r--r--app-text/rarian/rarian-0.8.1-r1.ebuild40
3 files changed, 61 insertions, 2 deletions
diff --git a/app-text/rarian/ChangeLog b/app-text/rarian/ChangeLog
index e6620b5e1e67..6da07352684b 100644
--- a/app-text/rarian/ChangeLog
+++ b/app-text/rarian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/rarian
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.41 2009/10/07 15:54:33 leio Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/ChangeLog,v 1.42 2010/03/12 12:27:24 pacho Exp $
+
+*rarian-0.8.1-r1 (12 Mar 2010)
+
+ 12 Mar 2010; Pacho Ramos <pacho@gentoo.org> +rarian-0.8.1-r1.ebuild,
+ +files/rarian-0.8.1-fix-old-doc.patch:
+ Fix bug 302900. Thanks to Rafał Mużyło for reporting and the patch.
07 Oct 2009; Mart Raudsepp <leio@gentoo.org>
-files/rarian-0.6.0-posix-getopt.patch,
diff --git a/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
new file mode 100644
index 000000000000..f84f987d8f10
--- /dev/null
+++ b/app-text/rarian/files/rarian-0.8.1-fix-old-doc.patch
@@ -0,0 +1,13 @@
+--- util/rarian-sk-preinstall.cpp.old 2008-09-01 20:40:21.000000000 +0200
++++ util/rarian-sk-preinstall.cpp 2010-01-30 11:29:39.000000000 +0100
+@@ -96,8 +96,8 @@
+ }
+ if (i == 1) {
+ /* Normal path. Add file:/ to the start */
+- new_url = (char *) malloc (sizeof(char) * (strlen (input) + 7));
+- sprintf (new_url, "file:/%s", input);
++ new_url = (char *) malloc (sizeof(char) * (strlen (input) + 8));
++ sprintf (new_url, "file://%s", input);
+ } else {
+ /* Don't know what to do. Just copy and append file: to it */
+ new_url = (char *) malloc (sizeof(char) * (strlen(input) + 6));
diff --git a/app-text/rarian/rarian-0.8.1-r1.ebuild b/app-text/rarian/rarian-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..421822877cfd
--- /dev/null
+++ b/app-text/rarian/rarian-0.8.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.8.1-r1.ebuild,v 1.1 2010/03/12 12:27:24 pacho Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A documentation metadata library"
+HOMEPAGE="http://www.freedesktop.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ !<app-text/scrollkeeper-9999"
+
+DOCS="ChangeLog NEWS README"
+
+GCONF=""
+
+src_unpack() {
+ # You cannot run src_unpack from gnome2; it will break the install by
+ # calling gnome2_omf_fix
+ unpack ${A}
+ cd "${S}"
+
+ # Fix uri of omf files produced by rarian-sk-preinstall, see bug #302900
+ epatch "${FILESDIR}/${P}-fix-old-doc.patch"
+
+ # remove unneeded line, bug #240564
+ sed "s/ (foreign dist-bzip2 dist-gzip)//" -i configure || die "sed failed"
+
+ elibtoolize ${ELTCONF}
+}
+
+src_compile() {
+ gnome2_src_compile --localstatedir=/var
+}