summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-12-18 06:30:57 +0000
committerNaohiro Aota <naota@gentoo.org>2011-12-18 06:30:57 +0000
commit9d7bfe8dda35940b497279cc932244e8a90bba7d (patch)
tree1d1c19453ff67d7da008e18812a3fe3b7721d1d7 /app-text
parentdie after sed. Don't call src_compile (diff)
downloadgentoo-2-9d7bfe8dda35940b497279cc932244e8a90bba7d.tar.gz
gentoo-2-9d7bfe8dda35940b497279cc932244e8a90bba7d.tar.bz2
gentoo-2-9d7bfe8dda35940b497279cc932244e8a90bba7d.zip
Add security fix. #390769
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/chasen/ChangeLog8
-rw-r--r--app-text/chasen/chasen-2.4.4-r2.ebuild64
-rw-r--r--app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch21
3 files changed, 92 insertions, 1 deletions
diff --git a/app-text/chasen/ChangeLog b/app-text/chasen/ChangeLog
index 4ed9bbfd1d1b..6a10f5de2211 100644
--- a/app-text/chasen/ChangeLog
+++ b/app-text/chasen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/chasen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/chasen/ChangeLog,v 1.42 2011/09/02 14:36:51 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/chasen/ChangeLog,v 1.43 2011/12/18 06:30:57 naota Exp $
+
+*chasen-2.4.4-r2 (18 Dec 2011)
+
+ 18 Dec 2011; Naohiro Aota <naota@gentoo.org> +chasen-2.4.4-r2.ebuild,
+ +files/chasen-2.4.4-cve-2011-4000.patch:
+ Add security fix. #390769
*chasen-2.4.4-r1 (02 Sep 2011)
diff --git a/app-text/chasen/chasen-2.4.4-r2.ebuild b/app-text/chasen/chasen-2.4.4-r2.ebuild
new file mode 100644
index 000000000000..f7ad6612f5ca
--- /dev/null
+++ b/app-text/chasen/chasen-2.4.4-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/chasen/chasen-2.4.4-r2.ebuild,v 1.1 2011/12/18 06:30:57 naota Exp $
+
+EAPI="4"
+inherit perl-module
+
+DESCRIPTION="Japanese Morphological Analysis System, ChaSen"
+HOMEPAGE="http://chasen-legacy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp//chasen-legacy/32224/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-solaris"
+IUSE="perl static-libs"
+
+DEPEND=">=dev-libs/darts-0.32"
+RDEPEND="${DEPEND}
+ perl? ( !dev-perl/Text-ChaSen )"
+PDEPEND=">=app-dicts/ipadic-2.7.0"
+
+src_preapre() {
+ epatch "${FILESDIR}"/${P}-cve-2011-4000.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ emake || die
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_compile
+ fi
+}
+
+src_test() {
+ emake check || die
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_test
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ if use perl ; then
+ cd "${S}"/perl
+ perl-module_src_install
+ newdoc README README.perl
+ fi
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+}
diff --git a/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch b/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch
new file mode 100644
index 000000000000..61480622e40a
--- /dev/null
+++ b/app-text/chasen/files/chasen-2.4.4-cve-2011-4000.patch
@@ -0,0 +1,21 @@
+diff --git a/lib/chalib.c b/lib/chalib.c
+index 5d79e13..cddf51b 100644
+--- a/lib/chalib.c
++++ b/lib/chalib.c
+@@ -306,9 +306,14 @@ chasen_sparse_main(char *input, FILE *output)
+ */
+ while (*input) {
+ int c = 0, len, cursor;
+- if ((crlf = strpbrk(input, "\r\n")) == NULL)
++ if ((crlf = strpbrk(input, "\r\n")) == NULL) {
+ len = strlen(input);
+- else {
++ if (len >= CHA_INPUT_SIZE) {
++ len = CHA_INPUT_SIZE - 1;
++ crlf = input + CHA_INPUT_SIZE - 2;
++ c = 0;
++ }
++ } else {
+ len = crlf - input;
+ c = *crlf;
+ *crlf = '\0';