summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Ehmsen <ehmsen@gentoo.org>2006-05-19 10:10:36 +0000
committerMartin Ehmsen <ehmsen@gentoo.org>2006-05-19 10:10:36 +0000
commitabf10b9a1b2154490c8ab5ed241707d7afa8e1da (patch)
treebe776550ec11dd7636b80f3b98697e507bd0ceea /app-text
parentFixed pstotext-1.9-quote-chars-fix.patch so input from stdin works. (diff)
downloadgentoo-2-abf10b9a1b2154490c8ab5ed241707d7afa8e1da.tar.gz
gentoo-2-abf10b9a1b2154490c8ab5ed241707d7afa8e1da.tar.bz2
gentoo-2-abf10b9a1b2154490c8ab5ed241707d7afa8e1da.zip
Fixed sparc mistake in 1.9-r1 and 1.9-r2 (sorry).
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pstotext/ChangeLog7
-rw-r--r--app-text/pstotext/files/digest-pstotext-1.9-r13
-rw-r--r--app-text/pstotext/pstotext-1.9-r1.ebuild36
-rw-r--r--app-text/pstotext/pstotext-1.9-r2.ebuild4
4 files changed, 47 insertions, 3 deletions
diff --git a/app-text/pstotext/ChangeLog b/app-text/pstotext/ChangeLog
index 4ec7233a2800..7bb86b0e7626 100644
--- a/app-text/pstotext/ChangeLog
+++ b/app-text/pstotext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pstotext
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/ChangeLog,v 1.21 2006/05/19 10:00:41 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/ChangeLog,v 1.22 2006/05/19 10:10:36 ehmsen Exp $
+
+ 19 May 2006; Martin Ehmsen <ehmsen@gentoo.org> +pstotext-1.9-r1.ebuild,
+ pstotext-1.9-r2.ebuild:
+ Forgot sparc marked 1.9-r1 stable, so readding it and changing -r2 to ~sparc
+ (argh!).
*pstotext-1.9-r2 (19 May 2006)
diff --git a/app-text/pstotext/files/digest-pstotext-1.9-r1 b/app-text/pstotext/files/digest-pstotext-1.9-r1
new file mode 100644
index 000000000000..f0cae0854c98
--- /dev/null
+++ b/app-text/pstotext/files/digest-pstotext-1.9-r1
@@ -0,0 +1,3 @@
+MD5 64576e8a10ff5514e285d98b3898ae78 pstotext-1.9.tar.gz 37461
+RMD160 16dc199d19df64280184d11ccbced7a32770ddad pstotext-1.9.tar.gz 37461
+SHA256 cfe0a251d0d43982a7d3bdf1d1670c854432739d00cb593c9beaca4b2cc36c27 pstotext-1.9.tar.gz 37461
diff --git a/app-text/pstotext/pstotext-1.9-r1.ebuild b/app-text/pstotext/pstotext-1.9-r1.ebuild
new file mode 100644
index 000000000000..a693633c2dd4
--- /dev/null
+++ b/app-text/pstotext/pstotext-1.9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r1.ebuild,v 1.4 2006/05/19 10:10:36 ehmsen Exp $
+
+inherit eutils
+
+DESCRIPTION="extract ASCII text from a PostScript or PDF file"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/doc/pstotext.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
+
+LICENSE="PSTT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/ncompress"
+
+RDEPEND="virtual/ghostscript"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.8g-dsafer.patch || die
+ # fix bug #132662
+ epatch "${FILESDIR}"/${P}-quote-chars-fix.patch || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ into /usr
+ dobin pstotext
+ doman pstotext.1
+}
diff --git a/app-text/pstotext/pstotext-1.9-r2.ebuild b/app-text/pstotext/pstotext-1.9-r2.ebuild
index cbf890682798..e03dac268833 100644
--- a/app-text/pstotext/pstotext-1.9-r2.ebuild
+++ b/app-text/pstotext/pstotext-1.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r2.ebuild,v 1.1 2006/05/19 10:00:41 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pstotext/pstotext-1.9-r2.ebuild,v 1.2 2006/05/19 10:10:36 ehmsen Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/contrib/${P}.tar.gz"
LICENSE="PSTT"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 sparc ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
DEPEND="app-arch/ncompress"