summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-31 06:53:38 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-31 06:53:38 +0000
commitb981c96d83b368f9a1805b28ab7f357844844666 (patch)
tree07d2ccd4400ff1a8e6c04de177d45ca06e6d757b /app-text
parentRemove dead code. (diff)
downloadgentoo-2-b981c96d83b368f9a1805b28ab7f357844844666.tar.gz
gentoo-2-b981c96d83b368f9a1805b28ab7f357844844666.tar.bz2
gentoo-2-b981c96d83b368f9a1805b28ab7f357844844666.zip
Move boost to DEPEND for all versions since it is not linked against, and move myhlopts setup out of pkg_setup and into src_compile since it is only used with src_* funcs.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/highlight/ChangeLog8
-rw-r--r--app-text/highlight/highlight-3.12.ebuild17
-rw-r--r--app-text/highlight/highlight-3.3.ebuild32
-rw-r--r--app-text/highlight/highlight-3.9.ebuild28
4 files changed, 44 insertions, 41 deletions
diff --git a/app-text/highlight/ChangeLog b/app-text/highlight/ChangeLog
index 76dd0d7b4857..d51824eee8f4 100644
--- a/app-text/highlight/ChangeLog
+++ b/app-text/highlight/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/highlight
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.57 2012/11/10 02:58:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/ChangeLog,v 1.58 2012/12/31 06:53:38 vapier Exp $
+
+ 31 Dec 2012; Mike Frysinger <vapier@gentoo.org> highlight-3.12.ebuild,
+ highlight-3.3.ebuild, highlight-3.9.ebuild:
+ Move boost to DEPEND for all versions since it is not linked against, and move
+ myhlopts setup out of pkg_setup and into src_compile since it is only used
+ with src_* funcs.
10 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> highlight-3.12.ebuild:
Drop usage of boost-utils since it's now pointless.
diff --git a/app-text/highlight/highlight-3.12.ebuild b/app-text/highlight/highlight-3.12.ebuild
index e7cc8a64e688..c309f7bdf7fa 100644
--- a/app-text/highlight/highlight-3.12.ebuild
+++ b/app-text/highlight/highlight-3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.12.ebuild,v 1.3 2012/11/10 02:58:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.12.ebuild,v 1.4 2012/12/31 06:53:38 vapier Exp $
EAPI=4
@@ -24,7 +24,12 @@ DEPEND="${RDEPEND}
dev-libs/boost
virtual/pkgconfig"
-pkg_setup() {
+src_prepare() {
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+}
+
+src_compile() {
myhlopts=(
"CXX=$(tc-getCXX)"
"AR=$(tc-getAR)"
@@ -38,14 +43,6 @@ pkg_setup() {
"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
"conf_dir=${EPREFIX}/etc/highlight/"
)
-}
-
-src_prepare() {
- sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
- src/core/datadir.cpp || die
-}
-
-src_compile() {
emake -f makefile "${myhlopts[@]}"
if use qt4 ; then
cd src/gui-qt
diff --git a/app-text/highlight/highlight-3.3.ebuild b/app-text/highlight/highlight-3.3.ebuild
index 5e6508ba3a2d..40136917281e 100644
--- a/app-text/highlight/highlight-3.3.ebuild
+++ b/app-text/highlight/highlight-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.3.ebuild,v 1.8 2012/01/22 15:30:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.3.ebuild,v 1.9 2012/12/31 06:53:38 vapier Exp $
EAPI=4
@@ -15,13 +15,22 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="examples qt4"
-DEPEND="dev-lang/lua
- dev-libs/boost
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-core:4 )"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-lang/lua
+ qt4? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
-pkg_setup() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+}
+
+src_compile() {
myhlopts=(
"CXX=$(tc-getCXX)"
"AR=$(tc-getAR)"
@@ -32,16 +41,7 @@ pkg_setup() {
"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
"conf_dir=${EPREFIX}/etc/highlight/"
)
-}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-parallel-make.patch
-
- sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
- src/core/datadir.cpp || die
-}
-
-src_compile() {
emake -f makefile "${myhlopts[@]}"
if use qt4 ; then
cd src/gui-qt
diff --git a/app-text/highlight/highlight-3.9.ebuild b/app-text/highlight/highlight-3.9.ebuild
index de9a09876873..1f4fd2fa1726 100644
--- a/app-text/highlight/highlight-3.9.ebuild
+++ b/app-text/highlight/highlight-3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.9.ebuild,v 1.2 2012/09/17 14:59:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-3.9.ebuild,v 1.3 2012/12/31 06:53:38 vapier Exp $
EAPI=4
@@ -15,13 +15,20 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="examples qt4"
-DEPEND="dev-lang/lua
- dev-libs/boost
- qt4? ( x11-libs/qt-gui:4
- x11-libs/qt-core:4 )"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-lang/lua
+ qt4? (
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
-pkg_setup() {
+src_prepare() {
+ sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
+ src/core/datadir.cpp || die
+}
+
+src_compile() {
myhlopts=(
"CXX=$(tc-getCXX)"
"AR=$(tc-getAR)"
@@ -35,14 +42,7 @@ pkg_setup() {
"doc_dir=${EPREFIX}/usr/share/doc/${PF}/"
"conf_dir=${EPREFIX}/etc/highlight/"
)
-}
-src_prepare() {
- sed -i -e "/LSB_DOC_DIR/s:doc/${PN}:doc/${PF}:" \
- src/core/datadir.cpp || die
-}
-
-src_compile() {
emake -f makefile "${myhlopts[@]}"
if use qt4 ; then
cd src/gui-qt