summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-08-04 20:27:19 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-08-04 20:27:19 +0000
commitbab8874574453d6bb9b2b9ff50da46eabd1729b7 (patch)
treea7705fc7fb388c76a48a4d509a5ccd1b23d61bbc /app-text
parentAdd live ebuild (diff)
downloadgentoo-2-bab8874574453d6bb9b2b9ff50da46eabd1729b7.tar.gz
gentoo-2-bab8874574453d6bb9b2b9ff50da46eabd1729b7.tar.bz2
gentoo-2-bab8874574453d6bb9b2b9ff50da46eabd1729b7.zip
Add live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libodfgen/ChangeLog7
-rw-r--r--app-text/libodfgen/libodfgen-9999.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-text/libodfgen/ChangeLog b/app-text/libodfgen/ChangeLog
index 9959d82f1d58..6eba1584bd51 100644
--- a/app-text/libodfgen/ChangeLog
+++ b/app-text/libodfgen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libodfgen
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.24 2015/07/22 19:33:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.25 2015/08/04 20:27:19 dilfridge Exp $
+
+*libodfgen-9999 (04 Aug 2015)
+
+ 04 Aug 2015; Andreas K. Huettel <dilfridge@gentoo.org> +libodfgen-9999.ebuild:
+ Add live ebuild
22 Jul 2015; Agostino Sarubbo <ago@gentoo.org> libodfgen-0.1.4.ebuild:
Stable for x86, wrt bug #555584
diff --git a/app-text/libodfgen/libodfgen-9999.ebuild b/app-text/libodfgen/libodfgen-9999.ebuild
new file mode 100644
index 000000000000..0f1bfda33570
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/libodfgen-9999.ebuild,v 1.1 2015/08/04 20:27:19 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/libodfgen"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}