summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-31 12:51:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-31 12:51:22 +0000
commitcbc490d32ae2b281c59e009378f22c03bd28dd57 (patch)
tree2cfa7c4b59b5c62f7c5e7629488048c31fae0b16 /app-text
parentDrop HPPA keywording. (diff)
downloadgentoo-2-cbc490d32ae2b281c59e009378f22c03bd28dd57.tar.gz
gentoo-2-cbc490d32ae2b281c59e009378f22c03bd28dd57.tar.bz2
gentoo-2-cbc490d32ae2b281c59e009378f22c03bd28dd57.zip
Version bump, with a totally new Gentoo patch to fix a bunch of issues (need to send that upstream). Also fix HOMEPAGE on old version.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libxmlpatch/ChangeLog12
-rw-r--r--app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch56
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild6
-rw-r--r--app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild41
4 files changed, 110 insertions, 5 deletions
diff --git a/app-text/libxmlpatch/ChangeLog b/app-text/libxmlpatch/ChangeLog
index bd15b22c130b..5149574fd179 100644
--- a/app-text/libxmlpatch/ChangeLog
+++ b/app-text/libxmlpatch/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/libxmlpatch
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/ChangeLog,v 1.1 2008/05/19 10:26:03 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/ChangeLog,v 1.2 2011/10/31 12:51:22 flameeyes Exp $
+
+*libxmlpatch-0.3.3 (31 Oct 2011)
+
+ 31 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/libxmlpatch-0.3.3-gentoo.patch, +libxmlpatch-0.3.3.ebuild,
+ libxmlpatch-0.3.1.ebuild:
+ Version bump, with a totally new Gentoo patch to fix a bunch of issues (need
+ to send that upstream). Also fix HOMEPAGE on old version.
*libxmlpatch-0.3.1 (19 May 2008)
diff --git a/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
new file mode 100644
index 000000000000..9238f3db04d8
--- /dev/null
+++ b/app-text/libxmlpatch/files/libxmlpatch-0.3.3-gentoo.patch
@@ -0,0 +1,56 @@
+Index: libxmlpatch-0.3.3/tests/check_diff.c
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/check_diff.c
++++ libxmlpatch-0.3.3/tests/check_diff.c
+@@ -259,7 +259,13 @@ static struct {
+ static void
+ add_test (TCase *tc, int i)
+ {
+- _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name, 0, 0, 1);
++ _tcase_add_test (tc, arr_tests[i].fn, arr_tests[i].name,
++#if CHECK_MAJOR_VERSION > 0 || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION > 9) || \
++ (CHECK_MAJOR_VERSION == 0 && CHECK_MINOR_VERSION == 9 && CHECK_MICRO_VERSION >= 8)
++ 0,
++#endif
++ 0, 0, 1);
+ }
+
+ static void
+Index: libxmlpatch-0.3.3/configure.in
+===================================================================
+--- libxmlpatch-0.3.3.orig/configure.in
++++ libxmlpatch-0.3.3/configure.in
+@@ -74,7 +74,13 @@ fi
+
+ PKG_CHECK_MODULES(DEPS_XML, libxml-2.0)
+ PKG_CHECK_MODULES(DEPS_GLIB, glib-2.0)
+-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4])
++
++AC_ARG_WITH([check],
++ AS_HELP_STRING([--without-check], [Do not build tests based on check package @<:@default=auto@:>@]))
++AS_IF([test "x$with_check" != "xno"], [
++PKG_CHECK_MODULES([CHECK], [check >= 0.9.4], , [with_check=no])
++])
++AM_CONDITIONAL([TESTS], [test "x$with_check" != "xno"])
+
+ AC_SUBST(DEPS_XML_CFLAGS)
+ AC_SUBST(DEPS_XML_LIBS)
+Index: libxmlpatch-0.3.3/tests/Makefile.am
+===================================================================
+--- libxmlpatch-0.3.3.orig/tests/Makefile.am
++++ libxmlpatch-0.3.3/tests/Makefile.am
+@@ -1,10 +1,11 @@
++if TESTS
+ TESTS = test-diff
++check_PROGRAMS = test-diff
++endif
+
+-test_PROGRAMS = test-diff
+ test_diff_SOURCES = check_diff.c
+ test_diff_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/diff @CHECK_CFLAGS@ $(DEPS_XML_CFLAGS) $(DEPS_GLIB_CFLAGS)
+ test_diff_LDADD = @CHECK_LIBS@ $(top_builddir)/src/libxmlpatch.la $(top_builddir)/diff/libxmldiff.la $(DEPS_XML_LIBS) $(DEPS_GLIB_LIBS)
+-testdir = $(libdir)/tests/xml_diff
+
+ bin_PROGRAMS = xml_patch xml_diff
+
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
index 0401c7a4a601..4f12a5bbd527 100644
--- a/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild,v 1.1 2008/05/19 10:26:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/libxmlpatch-0.3.1.ebuild,v 1.2 2011/10/31 12:51:22 flameeyes Exp $
inherit eutils autotools
DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
-HOMEPAGE="http://opensource.nokia.com/projects/xmlpatch/index.html"
+HOMEPAGE="http://xmlpatch.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
LICENSE="LGPL-2.1"
diff --git a/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
new file mode 100644
index 000000000000..fbb8839b9223
--- /dev/null
+++ b/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libxmlpatch/libxmlpatch-0.3.3.ebuild,v 1.1 2011/10/31 12:51:22 flameeyes Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A set of tools to create and apply patch to XML files using XPath"
+HOMEPAGE="http://xmlpatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/lib}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with test check)
+}
+
+DOCS=( LEGAL_NOTICE README TODO AUTHORS NEWS ChangeLog )
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete
+} \ No newline at end of file