summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 15:02:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 15:02:16 +0000
commite7d49ab59eca02037c538a544d1486987f4268bc (patch)
tree22e9adf7857e6b880606d07160a442805175c9a8 /app-text
parentFix building with libpng15 (including missing zlib.h include) wrt #380437 by ... (diff)
downloadgentoo-2-e7d49ab59eca02037c538a544d1486987f4268bc.tar.gz
gentoo-2-e7d49ab59eca02037c538a544d1486987f4268bc.tar.bz2
gentoo-2-e7d49ab59eca02037c538a544d1486987f4268bc.zip
Fix building with libpng15 (missing zlib.h include) wrt #378509 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdf2html/ChangeLog9
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-libpng15.patch10
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild32
3 files changed, 34 insertions, 17 deletions
diff --git a/app-text/pdf2html/ChangeLog b/app-text/pdf2html/ChangeLog
index beb61e799883..24e0d0f85631 100644
--- a/app-text/pdf2html/ChangeLog
+++ b/app-text/pdf2html/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pdf2html
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/ChangeLog,v 1.18 2009/12/26 19:27:30 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/ChangeLog,v 1.19 2011/09/14 15:02:16 ssuominen Exp $
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> pdf2html-1.4.ebuild,
+ +files/pdf2html-1.4-libpng15.patch:
+ Fix building with libpng15 (missing zlib.h include) wrt #378509 by Diego Elio
+ Pettenò
26 Dec 2009; Peter Volkov <pva@gentoo.org> pdf2html-1.4.ebuild:
virtual/ghostscript->app-text/ghostscript-gpl: ghostscript-gpl is the only
diff --git a/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
new file mode 100644
index 000000000000..72a0e1b65af9
--- /dev/null
+++ b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
@@ -0,0 +1,10 @@
+--- pbm2png.c
++++ pbm2png.c
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
++#include <zlib.h> /* Z_BEST_COMPRESSION */
+ #include <png.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
index 2f9f5317e945..bb06b51de3c1 100644
--- a/app-text/pdf2html/pdf2html-1.4.ebuild
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -1,27 +1,29 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/pdf2html-1.4.ebuild,v 1.18 2009/12/26 19:27:30 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/pdf2html-1.4.ebuild,v 1.19 2011/09/14 15:02:16 ssuominen Exp $
+EAPI=4
inherit eutils toolchain-funcs
DESCRIPTION="Converts pdf files to html files"
-SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
-LICENSE="GPL-2"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 ~ppc sparc x86"
IUSE=""
-SLOT="0"
-DEPEND=">=media-libs/libpng-1.2.5"
+DEPEND=">=media-libs/libpng-1.4
+ sys-libs/zlib"
RDEPEND="${DEPEND}
app-text/ghostscript-gpl
- >=media-gfx/imagemagick-5.4.9"
+ >=media-gfx/imagemagick-6"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.patch"
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
}
src_compile() {
@@ -29,18 +31,18 @@ src_compile() {
# Rewrite the Makefile as that's simpler
echo "LDLIBS=-lpng" > Makefile
echo "all: pbm2png" >> Makefile
- emake || die "failed to compile pbm2png"
+ emake
echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
- emake pbm2eps9 || die "failed to compile pbm2eps9"
+ emake pbm2eps9
echo "cp /usr/share/${P}/*.png ." >> pdf2html
}
src_install() {
- dobin pbm2png pbm2eps9 pdf2html ps2eps9 || die "install failed"
+ dobin pbm2png pbm2eps9 pdf2html ps2eps9
insinto /usr/share/${P}
doins *.png *.html
- dodoc CHANGELOG README VERSION || die "install failed"
+ dodoc CHANGELOG README VERSION
}