summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-06 00:26:07 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-06 00:26:07 +0000
commite90a94abb547b2e7338ada92ea2045e669adcc6a (patch)
treed26fa929bc70470dd6e5ced121721bf6645e0a32 /app-text
parentVersion bump. Raises encoder rank from NONE to SECONDARY, allowing it to be a... (diff)
downloadgentoo-2-e90a94abb547b2e7338ada92ea2045e669adcc6a.tar.gz
gentoo-2-e90a94abb547b2e7338ada92ea2045e669adcc6a.tar.bz2
gentoo-2-e90a94abb547b2e7338ada92ea2045e669adcc6a.zip
Bump to EAPI=3, add prefix keywords
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sablotron/ChangeLog5
-rw-r--r--app-text/sablotron/sablotron-1.0.3.ebuild26
2 files changed, 14 insertions, 17 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 5fbb58abc8fc..689c72a53b9b 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/sablotron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.67 2010/02/06 14:19:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.68 2010/04/06 00:26:07 abcd Exp $
+
+ 06 Apr 2010; Jonathan Callen <abcd@gentoo.org> sablotron-1.0.3.ebuild:
+ Bump to EAPI=3, add prefix keywords
06 Feb 2010; Torsten Veller <tove@gentoo.org> sablotron-1.0.3.ebuild:
Prepare in the correct directory (#300798)
diff --git a/app-text/sablotron/sablotron-1.0.3.ebuild b/app-text/sablotron/sablotron-1.0.3.ebuild
index d6cc9625d92a..aef982ced097 100644
--- a/app-text/sablotron/sablotron-1.0.3.ebuild
+++ b/app-text/sablotron/sablotron-1.0.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.3.ebuild,v 1.12 2010/02/06 14:19:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.3.ebuild,v 1.13 2010/04/06 00:26:07 abcd Exp $
+
+EAPI="3"
inherit base autotools
@@ -15,7 +17,7 @@ SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
# Sablotron can optionally be built under GPL, using MPL for now
LICENSE="MPL-1.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="perl"
RDEPEND=">=dev-libs/expat-1.95.6-r1"
@@ -24,27 +26,19 @@ DEPEND="${RDEPEND}
PATCHES="${FILESDIR}/1.0.3-libsablot-expat.patch"
-src_unpack() {
- base_src_unpack
-
- cd "${S}"
+src_prepare() {
eautoreconf
elibtoolize
}
-src_compile() {
- # Don't use --without-html-dir, since that ends up installing files under
- # the /no directory
- local myconf="--with-html-dir=/usr/share/doc/${PF}/html"
-
- use perl && myconf="${myconf} --enable-perlconnect"
-
- econf ${myconf} || die "Configure failed"
- emake || die "Make failed"
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}
src_install() {
- make DESTDIR="${D}" install || die "Install failed"
+ emake DESTDIR="${D}" install || die "Install failed"
dodoc README README_JS RELEASE src/TODO
}