summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-09 18:33:38 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-09 18:33:38 +0000
commitebac892116cd894100560f166c4ee65bf95a1719 (patch)
tree7d8e72d2dbbecf56d29fea2216f85ac77c20e663 /app-text
parentFix underlinking issue with zlib (bug #512728). (diff)
downloadgentoo-2-ebac892116cd894100560f166c4ee65bf95a1719.tar.gz
gentoo-2-ebac892116cd894100560f166c4ee65bf95a1719.tar.bz2
gentoo-2-ebac892116cd894100560f166c4ee65bf95a1719.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/qpdf/ChangeLog7
-rw-r--r--app-text/qpdf/qpdf-5.1.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/qpdf/ChangeLog b/app-text/qpdf/ChangeLog
index 2b47672ee9c6..1296cd9a8378 100644
--- a/app-text/qpdf/ChangeLog
+++ b/app-text/qpdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/qpdf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/ChangeLog,v 1.46 2014/06/08 11:07:58 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/ChangeLog,v 1.47 2014/06/09 18:33:38 radhermit Exp $
+
+*qpdf-5.1.2 (09 Jun 2014)
+
+ 09 Jun 2014; Tim Harder <radhermit@gentoo.org> +qpdf-5.1.2.ebuild:
+ Version bump.
08 Jun 2014; Agostino Sarubbo <ago@gentoo.org> qpdf-5.1.1.ebuild:
Stable for ppc, wrt bug #508134
diff --git a/app-text/qpdf/qpdf-5.1.2.ebuild b/app-text/qpdf/qpdf-5.1.2.ebuild
new file mode 100644
index 000000000000..8a044b2f5a77
--- /dev/null
+++ b/app-text/qpdf/qpdf-5.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/qpdf/qpdf-5.1.2.ebuild,v 1.1 2014/06/09 18:33:38 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A command-line program that does structural, content-preserving transformations on PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0/13" # subslot = libqpdf soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint ~sparc-solaris"
+IUSE="doc examples static-libs test"
+
+RDEPEND="dev-libs/libpcre
+ sys-libs/zlib
+ >=dev-lang/perl-5.8"
+DEPEND="${RDEPEND}
+ test? (
+ sys-apps/diffutils
+ media-libs/tiff
+ app-text/ghostscript-gpl
+ )"
+
+DOCS=( ChangeLog README TODO )
+
+src_prepare() {
+ # manually install docs
+ sed -i "/docdir/d" make/libtool.mk || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test test-compare-images)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc doc/qpdf-manual.pdf
+ dohtml doc/*
+ fi
+
+ if use examples ; then
+ dobin examples/build/.libs/*
+ fi
+
+ prune_libtool_files
+}