summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-23 17:29:24 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-23 17:29:24 +0000
commitf5280af3a39f07a1cce1362fcad536f87755b7a5 (patch)
treec5fb1158f1b1e341301e7288308ec9481a1a6109 /app-text
parentppc64 stable wrt #371673 (diff)
downloadgentoo-2-f5280af3a39f07a1cce1362fcad536f87755b7a5.tar.gz
gentoo-2-f5280af3a39f07a1cce1362fcad536f87755b7a5.tar.bz2
gentoo-2-f5280af3a39f07a1cce1362fcad536f87755b7a5.zip
Version bump. Block older version due to bug #326685.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kiwix/ChangeLog10
-rw-r--r--app-text/kiwix/kiwix-0.9_beta1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/app-text/kiwix/ChangeLog b/app-text/kiwix/ChangeLog
index 0347d93413cf..7361fa4331fe 100644
--- a/app-text/kiwix/ChangeLog
+++ b/app-text/kiwix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kiwix
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kiwix/ChangeLog,v 1.3 2010/12/12 16:50:40 chithanh Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kiwix/ChangeLog,v 1.4 2011/07/23 17:29:24 chithanh Exp $
+
+*kiwix-0.9_beta1 (23 Jul 2011)
+
+ 23 Jul 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +kiwix-0.9_beta1.ebuild:
+ Version bump.
*kiwix-0.9_alpha7 (12 Dec 2010)
diff --git a/app-text/kiwix/kiwix-0.9_beta1.ebuild b/app-text/kiwix/kiwix-0.9_beta1.ebuild
new file mode 100644
index 000000000000..8976e0968553
--- /dev/null
+++ b/app-text/kiwix/kiwix-0.9_beta1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kiwix/kiwix-0.9_beta1.ebuild,v 1.1 2011/07/23 17:29:24 chithanh Exp $
+
+EAPI=3
+
+inherit multilib versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)-src"
+
+DESCRIPTION="A ZIM reader, especially for offline web content retrieved from Wikipedia"
+HOMEPAGE="http://www.kiwix.org/"
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# sys-apps/portage botches upgrade, bug #326685
+RDEPEND="app-arch/xz-utils
+ dev-lang/perl
+ dev-libs/icu
+ dev-libs/xapian
+ net-libs/libmicrohttpd
+ net-libs/xulrunner:1.9
+ >=net-misc/aria2-1.10
+ !!<app-text/kiwix-0.9_beta"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS CHANGELOG README || die
+}