summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-11-21 20:46:07 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-11-21 20:46:07 +0000
commita3a1e64308b98baa4acdcfbaa483edb9aa5552d7 (patch)
tree042372db5c626dc11476398de506a05ffc90f94f /app-vim/align/align-33.ebuild
parentNew molecular graphics package. GLUT license is for files/glutbitmap.h. (diff)
downloadgentoo-2-a3a1e64308b98baa4acdcfbaa483edb9aa5552d7.tar.gz
gentoo-2-a3a1e64308b98baa4acdcfbaa483edb9aa5552d7.tar.bz2
gentoo-2-a3a1e64308b98baa4acdcfbaa483edb9aa5552d7.zip
New version. Tidy up old versions.
(Portage version: 2.0.53_rc7 fnord)
Diffstat (limited to 'app-vim/align/align-33.ebuild')
-rw-r--r--app-vim/align/align-33.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/align/align-33.ebuild b/app-vim/align/align-33.ebuild
new file mode 100644
index 000000000000..548f45b2365f
--- /dev/null
+++ b/app-vim/align/align-33.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/align/align-33.ebuild,v 1.1 2005/11/21 20:46:07 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: commands and maps to help produce aligned text"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=294"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="app-vim/cecutil"
+
+VIM_PLUGIN_HELPFILES="align align-maps"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # this makes vim7 throw a hissy fit
+ sed -i -e 's/ version </ v:version </g' plugin/Align*.vim || die "bad sed"
+
+ # nuke cecutil, we use the common shared version
+ rm -f plugin/cecutil.vim
+}
+