summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-11-18 18:41:03 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-11-18 18:41:03 +0000
commitb8d6ff0463d4e057199e4fef632db79209530e7f (patch)
tree2fec19e6a63b93002fa0d53ff02764ab3f782ae2 /app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
parent2Marked stalbe on x86 (Manifest recommit) (diff)
downloadgentoo-2-b8d6ff0463d4e057199e4fef632db79209530e7f.tar.gz
gentoo-2-b8d6ff0463d4e057199e4fef632db79209530e7f.tar.bz2
gentoo-2-b8d6ff0463d4e057199e4fef632db79209530e7f.zip
Version bump. Change ftdetect rules slightly, bug #71197
Diffstat (limited to 'app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild')
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
new file mode 100644
index 000000000000..886bc2a28fad
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild,v 1.1 2004/11/18 18:41:03 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~mips ~ppc"
+IUSE=""
+
+RDEPEND="${RDEPEND} >=app-vim/genindent-1.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # no ftdetect file provided. lame...
+ mkdir ftdetect
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim
+}
+