summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-25 09:48:47 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-25 09:48:47 +0000
commit8e535ecb39b9b578870be1586266da84fa76cb5e (patch)
tree106e0096b561877ee13415f2f4c32257cf3a8dee /app-vim/vim-r
parent[bump] dev-perl/HTTP-DAV-0.440.0 (diff)
downloadgentoo-2-8e535ecb39b9b578870be1586266da84fa76cb5e.tar.gz
gentoo-2-8e535ecb39b9b578870be1586266da84fa76cb5e.tar.bz2
gentoo-2-8e535ecb39b9b578870be1586266da84fa76cb5e.zip
Version bump. Use github mirror.
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/vim-r')
-rw-r--r--app-vim/vim-r/ChangeLog7
-rw-r--r--app-vim/vim-r/vim-r-110614.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/vim-r/ChangeLog b/app-vim/vim-r/ChangeLog
index 623a3a3ce945..0e15cf6a4a02 100644
--- a/app-vim/vim-r/ChangeLog
+++ b/app-vim/vim-r/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vim-r
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-r/ChangeLog,v 1.1 2011/03/14 07:21:34 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-r/ChangeLog,v 1.2 2011/06/25 09:48:47 radhermit Exp $
+
+*vim-r-110614 (25 Jun 2011)
+
+ 25 Jun 2011; Tim Harder <radhermit@gentoo.org> +vim-r-110614.ebuild:
+ Version bump. Use github mirror.
*vim-r-110222 (14 Mar 2011)
diff --git a/app-vim/vim-r/vim-r-110614.ebuild b/app-vim/vim-r/vim-r-110614.ebuild
new file mode 100644
index 000000000000..5928202e9f48
--- /dev/null
+++ b/app-vim/vim-r/vim-r-110614.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vim-r/vim-r-110614.ebuild,v 1.1 2011/06/25 09:48:47 radhermit Exp $
+
+EAPI="4"
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_PN="Vim-R-plugin"
+DESCRIPTION="vim plugin: integrate vim with R"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2628"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/R
+ || ( app-vim/conque app-vim/screen )"
+
+VIM_PLUGIN_HELPFILES="r-plugin.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README
+}