summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-29 00:40:50 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-29 00:40:50 +0000
commit3c545649be46cc0ba4bbc1f30c7b0a17176650f3 (patch)
treec163f07cd555bc63faa9844e052bcd0b56b147c0 /app-vim
parentInitial import. (diff)
downloadgentoo-2-3c545649be46cc0ba4bbc1f30c7b0a17176650f3.tar.gz
gentoo-2-3c545649be46cc0ba4bbc1f30c7b0a17176650f3.tar.bz2
gentoo-2-3c545649be46cc0ba4bbc1f30c7b0a17176650f3.zip
Initial import.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/easytags/ChangeLog10
-rw-r--r--app-vim/easytags/easytags-2.4.9.ebuild35
-rw-r--r--app-vim/easytags/metadata.xml5
3 files changed, 50 insertions, 0 deletions
diff --git a/app-vim/easytags/ChangeLog b/app-vim/easytags/ChangeLog
new file mode 100644
index 000000000000..859e081815e5
--- /dev/null
+++ b/app-vim/easytags/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/easytags
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.1 2011/06/29 00:40:50 radhermit Exp $
+
+*easytags-2.4.9 (29 Jun 2011)
+
+ 29 Jun 2011; Tim Harder <radhermit@gentoo.org> +easytags-2.4.9.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/easytags/easytags-2.4.9.ebuild b/app-vim/easytags/easytags-2.4.9.ebuild
new file mode 100644
index 000000000000..ffff28cf0443
--- /dev/null
+++ b/app-vim/easytags/easytags-2.4.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/easytags-2.4.9.ebuild,v 1.1 2011/06/29 00:40:50 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="easytags.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ rm INSTALL.md README.md
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ # Make scripts executable
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+}
diff --git a/app-vim/easytags/metadata.xml b/app-vim/easytags/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/easytags/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>